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Getting Started with AutoDocSearch

WHAT IS IT?

The AutoDocSearch is a plug-in for Adobe Acrobat software for searching, reporting and
performing content-depended processing and organizing of PDF documents.

FUNCTIONALITY OVERVIEW
Use this software for:

1. Searching multiple PDF documents for occurrence of one or more search terms or text patterns.
2. Create hyperlinked search reports in HTML and spreadsheet-ready formats.

3. Copy PDF files into specific folders based on occurrences of specific search terms or text
patterns.

Perform custom document processing using Acrobat JavaScript based on search results.

Review search results using interactive interface.

Bookmark and/or highlight matching text in PDF documents.

Use “Search and Copy” command in Action Wizard workflows for batch processing of PDF
documents without user interaction.

~N o v A

Example 1: The software can take multiple PDF files and search them for occurrences of last names
from the specified search list and produce a hyperlinked HTML report listing all matching document
locations. Search results can be easily viewed in the browser and navigated by clicking on report
entries.

Example 2: The software can take multiple PDF files that represent invoices and organize them into
different folders based on company names or invoice numbers.

SYSTEM REQUIREMENTS

The AutoDocSearch is a plug-in for Adobe Acrobat (version 6.0 and up). It requires Windows OS
version 7, 8, or 10.

Important: this product does not work with free Acrobat Reader, it requires full version of Adobe
Acrobat.

The product information page is located at:
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Getting Started with AutoDocSearch

SEARCHING FOR A LIST OF COMPANY NAMES

In this section we will demonstrate how to use AutoDocSearch to search PDF documents for a list of
company names and create a hyperlinked report listing all found document locations.

Here is a sample page from one of the documents we are going to search:

Solar Systems, LLC. I NVOICE

Advanced Electric Solutions

2397 NW Walnut Drive

Corvallis, OR, 97330 INVOICE #8474
WWW.evermap.com DATE: NOVEMBER 6, 2016
BILL TO: SHIP TO:

Accounts Payable Oregon Renewables LLC

Oregon Renewables LLC 2345 NW Pacific Avenue

2345 NW Pacific Avenue Portland, OR, 97203

Portland, OR, 97203

1. To begin, open Adobe Acrobat and select "Plug-ins > AutoDocSearch Plug-in > Search PDF
Files... " from the main menu of Adobe Acrobat:

File Edit View FHEGEHREY Window Help

AutoDocSearch Plug-in  * Search PDF Files...

Process Files Based On Text Search Rules...

Documentation and Getting Started ’

My Computer

Document Cloud
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Getting Started with AutoDocSearch

2. The "Search PDF File" dialog appears on the screen. Type (or copy/paste) all search text into the
list, one search term per line:

File Settings Help

Enter one search term per line in the form below:

Oregon Renewables

Northwest Natural Gas TYPE OR COPY/PASTE SEARCH

Columbia Sportswear TEXT INTO THE LIST
Clear Creek Distillery

Rogue Ales

Oregon Steel Mills

Cascade Yachts

IColumbia River Shipbuilding Company
Commercial Iron Works

Kaiser Shipyards

Northwest Steel

Oregon Shipbuilding Corporation
Sause Bros

Willamette Iron and Steel Works
Zidell Companies

Foris Vineyards Winery

HillCrest Vineyards

King Estate Winery

Maison Joseph Drouhin

Oak Knoll Winery

Sokol Blosser Winery UNCHECK “USE REGULAR

Trisaetum Winery "
Valley View Winery EXPRESSIONS” OPTION

[ I Match text case

Options... Cancel

3. Uncheck "Use regular expressions” option to use a plain text search.

4. Use "File > Save Search List” menu to save search list for future re-use. It can be loaded back
later by using “File > Load Search List” menu.

5. Press "Next>>" button to advance to input file/folder selection step. Use "Add Files..” and "Add
Folder..” buttons to select input PDF files:

Use “Add Files...” button to select PDF files that need to be processed.
Add Files... ‘ Add Folder... ‘ Remove File(s) ‘ 2

Selected Files

C:\Data\Invoices\AccountNumbers Invoices (1).pdf
£¢:\Data\Invoices\AccountNumbers Invoices (2).pdf
B¢:\Data\Invoices\AccountNumbers Invoices (3).pdf
C:\Data\Invoices\AccountNumbers Invoices (4).pdf
¢:\Data\Invoices\AccountNumbers Invoices (5).pdf
B¢:\Data\Invoices\AccountNumbers Invoices (6).pdf
@C:\Dam\Invoices\AccountNumbers Invoices (7).pdf
C:\Data\Invoices\AccountNumbers Invoices (8).pdf
£¢:\Data\Invoices\AccountNumbers Invoices (9).pdf
aC:\Data\Invoices\AccountNumbers Invoices (10).pdf
C:\Data\Invoices\AccountNumbers Invoices (11).pdf
£¢:\Data\Invoices\AccountNumbers Invoices (12).pdf
B¢:\Data\Invoices\AccountNumbers Invoices (13).pdf
C:\Data\Invoices\AccountNumbers Invoices (14).pdf
¢:\Data\Invoices\AccountNumbers Invoices (15).pdf
£¢:\Data\Invoices\AccountNumbers Invoices (16).pdf
@C:\Dam\Invoices\AccountNumbers Invoices (17).pdf
C:\Data\Invoices\AccountNumbers Invoices (18).pdf
B¢:\Data\Invoices\AccountNumbers Invoices (19).pdf

19 file(s) have been selected for processing. oK Cancel
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Getting Started with AutoDocSearch

6. Press "OK" button to start searching. Once the search is completed, the “Search Results” dialog
is shown. The dialog is resizable. Change its size and positon to simply viewing:

File Help

Total number of matches found: 26
Click on list entries to display text location:
Hao® 2]

Text Match Page File

Oregon Renewables 1 Invoices 2016.pdf
Oregon Renewables 1 Invoices 2016.pdf CLICK ON RESULTS TO OPEN
Oregon Renewables W CORRESPONDING LOCATION
Northwest Natural Gas Invoices 2016.pdf

Columbia Sportswear Invoices 2016.pdf

4
Clear Creek Distillery 5 Invoices 2016.pdf
Rogue Ales 6 Invoices 2016.pdf
7
8

Oregon Steel Mills Invoices 2016.pdf
Cascade Yachts Invoices 2016.pdf
Columbia River Shipbuilding Co... 9 Invoices 2016.pdf
Commercial Iron Works 10 Invoices 2016.pdf
Kaiser Shipyards 11 Invoices 2016.pdf
Northwest Steel 12 Invoices 2016.pdf
Oregon Shipbuilding Corporation 13 Invoices 2016.pdf
Sause Bros 14 Invoices 2016.pdf
Willamette Iron and Steel Works 15 Invoices 2016.pdf
Zidell Companies 16 Invoices 2016.pdf
Foris Vineyards Winery 17 Invoices 2016.pdf
HillCrest Vineyards 18 Invoices 2016.pdf
King Estate Winery Invoices 2016.pdf
Maison Joseph Drouhin Invoices 2016.pdf
Oak Knoll Winery Invoices 2016.pdf
Sokol Blosser Winery Invoices 2016.pdf
Trisaetum Winery Invoices 2016.pdf
Valley View Winery Invoices 2016.pdf
Willamette Valley Vineyards Invoices 2016.pdf

L 4 >

Save Search Report
°

7. Click on any search result in the list to open a corresponding PDF document and display the text
location. The matching text is going to be selected on the page.
8. Use toolbar button to bookmark or highlight matching text in the documents:

Total number of matches found: 26
Click on list entries to display text location:
Ha &® —

AN

Use this button to Use these buttons to
bookmark text location highlight text location
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Getting Started with AutoDocSearch

Click "Save Search Report” link or use “File > Save Search Report” menu to save current search

results as HTML report file:

Foris Vineyards Winery 17 Invoices 2016.pdf
HillCrest Vineyards 18 Invoices 2016.pdf
King Estate Winery 19 Invoices 2016.pdf
Maison Joseph Drouhin 20 Invoices 2016.pdf
Oak Knoll Winery 21 Invoices 2016.pdf
Sokol Blosser Winery 22 Invoices 2016.pdf
Trisaetum Winery 23 Invoices 2016.pdf
Valley View Winery 24 Invoices 2016.pdf
Willamette Valley Vineyards 25 Invoices 2016.pdf

>

<
Save Search Report
(SR

The search report is automatically open in the web browser. Here is an example of the search report:

AutoDocSearch Text Search Report

Processing Date : 11/06/16 12:56:59
User Name : Admin

Computer Name : OREGONPC
Adobe Acrobat Version : 15.1536
Software Build Date : Nov 1 2016

Processing Summary

e Total number of rules used for searching: 24
e Total number of text matches found: 26

e Total number of input files searched: 1

o Total number of files without any text matches: 0
e Total number of rules applied to files: 0

e Total number of times rules have been applied to files:
e Total number of files copied by the rules: 0

Rules Summary

CLICK ON THE SEARCH RULE LINK TO JUMP TO
ALL MATCHING TEXT FOR THAT SEARCH TERM

Rule 1: (), Search text: Oregon Renewables, Number of matches: 3, Files applied to: 0, Files copied: 0

Rule 2: (), Search text: Northwest Natural Gas, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 3: (), Search text: Columbia Sportswear, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 4: (), Search text: Clear Creek Distillery, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 5: (), Search text: Rogue Ales, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 6: (), Search text: Oregon Steel Mills, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 7: (), Search text: Cascade Yachts, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 8: (), Search text: Columbia River Shipbuilding Company, Number of matches: 1, Files applied to: 0, Files copied: 0
Rule 9: (), Search text: Commercial Iron Works, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 10: (), Search text: Kaiser Shipyards, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 11: (), Search text: Northwest Steel, Number of matches: 1, Files applied to: O, Files copied: 0

Rule 12: (), Search text: Oregon Shipbuilding Corporation, Number of matches: 1, Files applied to: 0, Files copied: 0
Rule 13: (), Search text: Sause Bros, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 14: (), Search text: Willamette Iron and Steel Works, Number of matches: 1, Files applied to: 0, Files copied: 0

Rule 16: (), Search text: Foris Vineyards Winery, Number of matches: 1, Files applied to: 0, Files copied: 0
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Getting Started with AutoDocSearch

The search report is organized into number of sections:

Processing Summary — this section list overall statistics such as number of input files and matches
found.

Rules Summary - this section lists all search terms used and number of matches found for each
search "rule”.

Processing Details — this section lists all matching text references organized by search “rule”:

Processing Details

Rule 1 (), Search text: Oregon Renewables, Number of matches: 3
Text matches:
1. File: C:\EverMap PDF\Test Documents\AutoDocSearch\Invoices 2016.pdf, Page: 1, Text found: Oregon Renewables

2. File: C:\EverMap PDF\Test Documents\AutoDocSearch\Invoices 2016.pdf, Page: 1, Text found: Oregon Renewables
3. File: C:\EverMap PDF\Test Documents\AutoDocSearch\Invoices 2016.pdf, Page: 2, Text found: Oregon Renewables

No files have been copied by this rule.

Rule 2 (), Search text: Northwest Natural Gas, Number of matches: 1
Text matches:

1. File: C:\EverMap PDF\Test Documents\AutoDocSearch\Invoices 2016.pdf, Page: 3, Text found: Northwest Natural Gas

No files have been copied by this rule.

Rule 3 (), Search text: Columbia Sportswear, Number of matches: 1
Text matches:

1. File: C:\EverMap PDF\Test Documents\AutoDocSearch\Invoices 2016.pdf, Page: 4, Text found: Columbia Sportswear

No files have been copied by this rule.
Rule 4 (), Search text: Clear Creek Distillery, Number of matches: 1

Text matches:

1. File: C:\EverMap PDF\Test Documents\AutoDocSearch\Invoices 2016.pdf, Page: 5, Text found: Clear Creek Distillery

No files have been copied by this rule.

) e T I L AN o Y I o vy AV I 2 N I R N = B N (PN [

Optionally, search results are automatically saved as spreadsheet-ready plain text CSV file. It can be
opened by Excel or any other spreadsheet editor as well as in any text editor. The spreadsheet lists all
details for every matching text location:

A B C D E F G H

1 |[File Page Text Left Right Top Bottom  Rule Number

2 |C:\EverMa 1 Oregon Renewables 41.4 119.4 643.6 631.2 1
3 |C:\EverMa 1 Oregon Renewables 3114 3894 654.9 642.5 1
4 |C:\EverMa 2 Oregon Renewables 36 106.5 756.3 744.7 1
5 |C:\EverMa 3 Northwest Natural Gas 36 115.8 745 733.4 2
6 |C:\EverMa 4 Columbia Sportswear 36 110.7 756.3 744.7 3
7 |C:\EverMa 5 Clear Creek Distillery 36 109 756.3 744.7 4
8 |C:\EverMa 6 Rogue Ales 36 75.2 756.3 744.7 5
9 |C:\EverMa 7 Oregon Steel Mills 36 99.6 756.3 7447 6
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SEARCHING FOR SOCIAL SECURITY NUMBERS

We will demonstrate how to use AutoDocSearch to search PDF documents for a specific text pattern
(social security number in this example) and create a hyperlinked report listing all found document
locations. This example illustrates the use of regular expression syntax for describing a text pattern.
You can think of regular expressions as wildcards with a lot more capabilities. Regular expressions
allow finding all text strings that fit a specific pattern. For example, to find phone or social security
numbers, a 10 digit account numbers that starts with 12, email addresses, zip/postal codes and etc.

Here is the sample page from one of the documents we are going to search (with social security
number highlighted):

E 0 0 Department of the Treasury—Intemal Revenue Service (99)
2 1 4 U.S. Individual Income Tax Return 2© 15

OMB No. 1545-0074

IR8 Use Only—Do not write or staple in this space.

For the year Jan. 1-Dec. 31, 2015, or other tax year beginning , 2015, ending ,20 See separate instructions.

Your first name and initial Last name Your social security number
JOHN SMITH (1507-93-1234

If a joint return, spouse’s first name and initial Last name i i ity number
MARY SMITH 507-93-4321

Home address (number and street). If you have a P.O. box, see instructions. Apt. no. A Make sure the SSN(s) above
2356 NW PACIFIC AVENUE and on line 6¢ are correct.

City, town or post office, state, and ZIP code. If you have a foreign address, also complete spaces below (see instructions). Presidential Election Campaign
PORTLAND, OR, 97203 Check here if you, or your spouse if filing

jointly, want $3 to go to this fund. Checking

Foreign country name Foreign province/state/county Foreign postal code a box below will not change your tax o
refund. [] You []spouse
Filing Status 1 [ single 4[] Head of household (with qualifying person). (See instructions.) If
I Married filing jointly (even if only one had income) the qualifying person is a child but not your dependent, enter this
Check only one 3 [_] Married filing separately. Enter spouse’s SSN above child’s name here. B
box. and full name here. p» 5 [7] Qualifying widow(er) with dependent child

9. To begin, open Adobe Acrobat and select "Plug-ins > AutoDocSearch Plug-in > Search PDF
Files... " from the main menu of Adobe Acrobat:

File Edit View JEEEEEEY Window Help

AutoDocSearch Plug-in » Search PDF Files...

Process Files Based On Text Search Rules...

Documentation and Getting Started ’

My Computer

Document Cloud
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10. The “Search PDF File" dialog appears on the screen.

File Settings Help

Enter one search term per line in the form below:

PRESS TO INSERT REGULAR
EXPRESSION FROM THE LIBRARY

[+] Use regular expressions [ Match text case

Options... Next>> Cancel

1. Press [...] button to select pattern from the library or type expression directly into the list.

Information

Q Use this dialog to add an item/element to a search expression. The dialog
will automatically add a regular expression element based on your

selection.

Select Text Category To Match

=INumbers

Single Digit

Two Digits

Three Digits

Ten Digits

One to Three Digits
One or More Digits
Zero or One Digit
Dollar Amount With Cents: XXXX.XX
one Number With Ar

US SSN Number: XXX-XX-XXXX|

+4 Code: XXXXX-

[+Letters

[+ Whitespace
[+/Punctuation
[+/Special Categories

SELECT TEXT PATTERN FROM THE

LIBRARY

Select item from list and click "OK" button

Cancel
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Getting Started with AutoDocSearch

Alternatively, type the following regular expression into the search list: \d{3}-\d{2}-\d{4}. This
expression describes the following text pattern: 3 digits, dash, 2 digits, dash, and 4 digits. This
pattern will match US social security numbers such as 507-93-1234 or 588-22-9238.

File Settings Help

Enter one search term per line in the form below:

d{3}-\d{23}-\d{4

ALTERNATIVELY, TYPE
EXPRESSION INTO THE LIST

CHECK “USE REGULAR
EXPRESSIONS" OPTION

Use regular expressions [ |Match text case

Options... Next>> Cancel

Make sure that “Use regular expressions” option is checked. If this option is checked, then
everything entered into a search list should conform to regular expression syntax. There are
countless online resources dedicated to regular expressions. Visit

for detailed description of the syntax. See “Brief Introduction to Regular
Expressions” topic below for a quick info on the basic syntax.

Use “File > Save Search List..” menu to save search list for future re-use. It can be loaded back
later by using “File > Load Search List..” menu. The search settings will be saved into a file with
* search extension. Use search file to store useful expressions for frequent use or for exchanging
settings with co-workers.

Optionally, press “Options.." button if you need to limit text search to a specific area on the page
or select a processing page range. It is also possible to search only text that matches a user-

defined font name and/or size.

Press “Next>>" button to advance to input file/folder selection step.
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16. Press "Add Files” or “Add Folder” button to select input files for searching:

Use “Add Files...” button to select PDF files that need to be processed.
Add Files... ‘ Add Folder... ‘ Remove File(s) ‘ 2

Selected Files

aC:\EverMap PDF\Test Documents\AutoDocSearch\SSN.pd!
ja C:\EverMap PDF\Test Documents\AutoDocSearch\SSN2.pdf]

FILES SELECTED FOR SEARCHING

2 file(s) have been selected for processing. ‘ OK ‘ ‘ Cancel ‘

17. Press "OK" button to start searching. Once the search is completed, the "Search Results” dialog is
shown. It shows the page number and file name for each matching text location. The dialog is
resizable — change its size and position to simply viewing:

File Help

Total number of matches found: 12

@ @ Click on list entries to display text location:

Text Match Page File
507-39-1234 SSN.pdf
548-45-4321 SSN.pdf
789-22-0987 SSN.pdf
423-11-4567 SSN.pdf
512-72-3344 SSN.pdf
322-55-1278 SSN.pdf
606-39-1234 SSN2.pdf
442-95-4321 SSN2.pdf
589-52-6687 SSN2.pdf
410-66-4522 SSN2.pdf
612-22-2367 SSN2.pdf
402-55-1668 SSN2.pdf RESIZE DIALOG FOR
BETTER VIEWING

DU R WNROOUDNAWNR

Save Search Report

M|Page
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18. Click on a list entry to open a corresponding PDF document and display a matching text location:

®PBERQ OO 2 /7 RMO® 2 - [§

File Help

Total number of matches found: 12
Click on list entries to display text location:
HaB®@® play

Text Match Page File
507-39-1234 1 SSN.pdf
789-22-0987 3 SSN.pdf
423-11-4567 SSN.pdf
512-72-3344 SSN.pdf
322-55-1278 SSN.pdf
548_45 _43 2 1 606-39-1234 SSN2.pdf
442-95-4321 SSN2.pdf

589-52-6687
410-66-4522
612-22-2367
402-55-1668

SSN2.pdf
SSN2.pdf
SSN2.pdf
SSN2.pdf

D UTDA WN = O U DN

Save Search Report

Click "Save Search Report” link or use “File > Save Search Report” menu to save current search results
as HTML report file. The report file will be automatically open in the web browser:

AutoDocSearch Text Search Report

Processing Date : 11/06/16 11:14:19
User Name : Admin

Computer Name : OREGONPC
Adobe Acrobat Version : 15.1536
Software Build Date : Nov 1 2016

Processing Summary

Total number of rules used for searching: 1

Total number of text matches found: 12

Total number of input files searched: 2

Total number of files without any text matches: 0

Total number of rules applied to files: 0

Total number of times rules have been applied to files: 0
Total number of files copied by the rules: 0

e 0o 00 000

Rules Summary
® Rule 1: (), Search text: \d{3}-\d{2}-\d{4}, Number of matches: 12, Files applied to: 0, Files copied: 0

Processing Details

Rule 1 (), Search text: \d{3}-\d{2}-\d{4}, Number of matches: 12

Text matches:

File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN.pdf, Page: 1, Text found: 507-39-1234
File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN.pdf, Page: 2, Text found: 548-45-4321
File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN.pdf, Page: 3, Text found: 789-22-0987
File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN.pdf, Page: 4, Text found: 423-11-4567
File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN.pdf, Page: 5, Text found: 512-72-3344
File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN.pdf, Page: 6, Text found: 322-55-1278
File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN2.pdf, Page: 1, Text found: 606-39-1234
File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN2.pdf, Page: 2, Text found: 442-95-4321
File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN2.pdf, Page: 3, Text found: 589-52-6687
10. File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN2.pdf, Page: 4, Text found: 410-66-4522
11. File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN2.pdf, Page: 5, Text found: 612-22-2367
12. File: C:\EverMap PDF\Test Documents\AutoDocSearch\SSN2.pdf, Page: 6, Text found: 402-55-1668

COINOGORWLN =

No files have been copied by this rule.
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Optionally, search results are automatically saved as spreadsheet-ready plain text CSV file. It can be
opened by Excel or any other spreadsheet editor as well as in any text editor. The spreadsheet lists
every matching location on a separate row, and records the following information: full path to the
PDF file, page number, matching text, text coordinates in the page measurement units (points) — left,
right, top and bottom, and a search rule number (index in the search list).

A B C D E F G H

1 |Fi|e |Page  Text Left Right Top Bottom  Rule Number

2 C:\EverMa 1 507-39-1234 72 128.9 720.8 706.2 1
3 C:\EverMa 2 548-45-4321 72 128.9 720.8 706.2 1
4 C:\EverMa 3 789-22-0987 72 128.9 720.8 706.2 1
5 C:\EverMa 4.423-11-4567 72 128.9 720.8 706.2 1
6 C:\EverMa 5 512-72-3344 72 128.9 720.8 706.2 1
7 C:\EverMa 6 322-55-1278 72 128.9 720.8 706.2 1
8 C:\EverMa 1 606-39-1234 72 128.9 720.8 706.2 1
9 C:\EverMa 2 442-95-4321 72 128.9 720.8 706.2 1
10 C:\EverMa 3 589-52-6687 72 128.9 720.8 706.2 1
11 C:\EverMa 4 410-66-4522 72 128.9 720.8 706.2 1
12 C:\EverMa 5 612-22-2367 72 128.9 720.8 706.2 1
13 C:\EverMa 6 402-55-1668 72 128.9 720.8 706.2 1

The text coordinates on the page are provided in PDF “user space” coordinate system and are
measured in “points” (there are 72 points per inch). The origin is located in the lower left corner of
the page and does not necessarily correspond to the bottom-left page corner. The origin location
depends on the page cropping settings used in the specific PDF document.

User Space Coordinate System

Media Box

Y

(0.0)
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ORGANIZING DOCUMENTS INTO FOLDERS BY SEARCH

It is often necessary to take a set of PDF documents and organize them into different folders based
on their content. For example, categorize incoming business documents into separate folders based
on the text search. Put all invoices into “Invoices” folder and purchase orders into “Orders”. Put the
rest of the documents that do not match neither of these categories into “Other” folder. The
following example, would assume that all invoices have the word “invoice” followed by a 3 to 8 digit
invoice number, while purchase orders have the word “purchase order” followed by a 4 to 10 digit
number. This chapter will illustrate how to configure AutoDocSearch to take documents from one or
more folders and copy them into one of the three different folders based on matching text.

R Y

Doc1.pdf Doc2.pdf Doc3.pdf Doc4.pdf

\ \
] ] ]

INVOICES ORDERS OTHER

STARTING “SEARCH AND COPY PDF FILES”

To begin, open Adobe Acrobat and select "Plug-ins > AutoDocSearch Plug-in > Process Files Based
on Text Search Rules..." from the main menu of Adobe Acrobat:

File Edit View FEHEEEESY Window Help

AutoDocSearch Plug-in  » Search PDF Files...
C__Process Files Based On Text Searc@
Documentation and Getting Started »

My Computer

Document Cloud
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The “Search and Copy PDF Files” dialog appears on the screen. This dialog provides controls for
creating one or more document processing rules and configuring application settings.

7 % Use this operation to search a group of PDF files for a set of text patterns. This operation will generate a detailed report for occurence of each search Help.
Q term. Optionally, copy files to selected folders.
Search Settings
Report file location:  C:\Users\Admin\Documents\AutoDocSearch Search Report.html Browse...
|| Create search report ( press "Options" for more settings)
Add Search Rule... ’ ,‘ f’ Ta ia v‘ o Find: = Reset Settings Options...
Search Expression Page Range Page Area Description JavaScript Action  Cofy To
PRESS TO ADD NEW PRESS TO SPECIFY
SEARCH RULES PROCESSING OPTIONS
SAVE AND LOAD RULES PRESS “NEXT" TO
TO/FROM FILES SELECT INPUT FILES

Save Settings... Load Settings... Next >> Cancel

The following example is going to demonstrate how to use text patterns for searching and
organizing PDF documents into multiple folders. In this tutorial, we are going to create two
processing rules. The first rule is going to search for invoice numbers while the second one is
going to look for purchase order numbers. If a document is matching a specific rule, it will be
copied to a pre-defined folder. The special “no match” rule is going to be setup in application
settings to process documents that did not match any of the rules. All documents without any
text matches are going to be copied into “other” folder.

ADDING A SEARCH RULE

Press "Add Search Rule..” button to specify a first processing rule for handling files that contain
invoice numbers. Use “Text Search Rule” dialog to specify a document processing rule. Basically, it
is necessary to specify a search text and a folder where to copy a document if a match is found.
You can use plain text or regular expression to search for text patterns. For example, type
Invoice \d+ into a “Find what” entry field. This is an expression that matches the word /nvoice
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followed by one or more digits. It will match text such as Invoice 03276487 or Invoice 9234. Make
sure to check "Use regular expressions” option when using regular expression syntax such as \d+.
Optionally, you can press “Add Search Item..”" button to pick an expression from a built-in library.

Options ENTER SEARCH

Find what: ([nvoice \d+ )™ EXPRESSION

Use regular expressions [ |Match case Add Search Item...

Description: ’Find invoices and copy files to "invoices" folder

|| stop searching a document using other rules once this text is found

Where to Search for Text

| |search for text only inside a specified area on the page Edit Area ...

Left: 0 pt/0 mm/0.00in Top: Opt/0mm/0.00in
Right: 0pt/0mm/0.00in Bottom: 0 pt/0mm/0.00in

Acrobat JavaScript Action

| | Execute this script after all matching text have been found What is scripting for?

. SELECT OUTPUT
Copy File FOLDER

Copy PDF file to a folder if it has a matching text

Folder: ’C:\Data\lnvoices\

Append After

File name: ’ + original file name | “Invoice

Help... Cancel

Check “Copy PDF file to a folder if it has a matching text” option and press “Browse..” button to
specify a destination folder where to copy files. All files that match this rule will be copied to the
selected folder. Optionally, use “Insert Before” and “Insert After” fields to modify file names of the
output files.

Press “OK" button once done editing this rule. Press “Add Search Rule..” button one more time and
repeat this procedure while specifying different search text and output folder for handling purchase
order documents. For example, use “Order \d+" as a search expression and select c:\Data\Orders
folder for the output.
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SPECIFYING “NO MATCH” RULE

The next step (optional) is to specify a “No Match” rule to copy files that do not match any of the
processing rules. If this is not required by your project, then you can skip this step. Press “Options..”
button to access application settings:

@ Use this operation to search a group of PDF files for a set of text patterns. This operation will generate a detailed report for occurence of each search Help.
term. Optionally, copy files to selected folders.

Search Settings PRESS TO SPECIFY

Report file location;  C:\Users\Admin\Documents\AutoDocSearch Search Report.html Y Y
’ NO-MATCH” RULE Bloite,

|v| Create search report ( press "Options" for more settings)

Add Search Rue... | # 4+ @ Ta La ¥ g Find: | Q Reset Settings Options...
Search Expression Page Range Page Area Description JavaScript Action Copy To
Orders \d+ Process All Pages |Whole page | Find purchase order numbers _ C:\Data\Orders\
Invoice \d+ Process All Pages Whole page  Find invoices and copy files to "invoice" folder C:\Data\Invoices\

Select "Apply special processing to files without any text matches” option and press “Edit Rule”
button:

Reporting Options

Append results to existing report file Output search results as CSV spreadsheet

Overwrite existing report file Show search results at the end of the processing

Handle Files Without Matching Text

Apply special processing to files without any text matches

Input Files Handling

| | Execute JavaScript code on each PDF files at the end of the processing Edit Script...

Processing Log

Enable processing log View Log ‘ ‘ Clear Log

OK ‘ ‘ Cancel
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The "Processing Rule” dialog will appear on the screen. Specify the destination folder by selecting
"Copy PDF file to a folder” option and press “Browse.." button to choose a destination folder. All files
that did not match any rule will be copied there.

Acrobat JavaScript Action

| | Execute Acrobat JavaScript code What is scripting for?

Copy File

Copy PDF file to a folder

Folder: ’C:\Data\Others\ (  Browse... b

Insert Before Append After

File name: ’ + original file name

Close the dialog by pressing the “OK” button and close the “Processing Options” dialog as well. Now
everything is ready for a test run.

Press “Next>>" button located in the lower-right cornet of the main screen to proceed to the
selection of input files or folders.

C  Next>> Cancel
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SELECTING INPUT FILES

Select input PDF files or folders for processing by pressing “Add Files..” and/or “Add Folder..”
buttons. Press the "OK” button to start processing files. If a folder is selected, then all PDF files
from this folder will be processed.

3 3 Use “Add Files...” button to select PDF files that need to be processed.
Add Files... Add Folder... Remove File(s)

Selected Files

B C:\Data\Input]

1 file(s) have been selected for processing.

Here is a content of “Input” folder before executing the processing. It contains 7 files:

Home Share View

@ ~ 1 | » ThisPC » OS(C) » Data » Input v ¢ Search Input

P

=
o
3
o

l? Favorites
I Desktop
4 Downloads

I
«» Recent places

Date modified Type

Doc 2321143.pdf 1/19/2017 9:14 AM Adobe Acrobat Document
Doc 2374843.pdf 1/19/2017 9:14 AM Adobe Acrobat Document
Doc 2997143.pdf 1/19/2017 9:14 AM Adobe Acrobat Document
Doc 4487133.pdf 1/19/2017 9:15 AM Adobe Acrobat Document
PO 66341285.pdf 1/19/2017 9:16 AM Adobe Acrobat Document
PO 929211285.pdf 1/19/2017 9:16 AM Adobe Acrobat Document
Purchase Order 83427498.pdf ~ 1/19/2017 4:51 AM Adobe Acrobat Document

A This PC
I Desktop
Ei Documents
14 Downloads
1) Music

7 items

[
=
o
=
=
=l
o
=
o
e
o
=
o
=
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Press the "OK" button to start processing. Note that searching a large number of PDF documents can
take some time depending on the number of rules used.

REVIEWING SEARCH RESULTS

Once the processing is completed, a “Search Results” dialog is shown on the screen. If you do not
want to display this dialog, then edit application settings by pressing “Options” button located on the
starting screen. There are a number of options available for the report generation.

SHOWS NUMBER OF TEXT MATCHES

File Help

Total number of matches found: 7
Click on list entries to display text location:
Hab®@ Y

Text Match Page File CLICK TO DISPLAY MATCHING TEXT

Order 66341285 PO 66341285.pdf

Order 929211285 1 PO 929211285.pdf

ORDER 83427498 1 Purchase Order 83427498.pdf
INVOICE 2321143 1 Doc 2321143.pdf
INVOICE 2374843 1 Doc 2374843.pdf
INVOICE 2997143 1 Doc 2997143.pdf
INVOICE 4487133 1 Doc 4487133.pdf

CLICK TO DISPLAY REPORT FILE

Open Search Report

This dialog shows the total number of matches for all rules used and provide a way to inspect text
locations in the PDF documents. Simply click on the search entry to display a matching text. This will
open a corresponding PDF document in a new window and highlight a matching text string.

REVIEWING REPORT FILE

Click on "Open Search Report” link in the bottom-left corner of the dialog to open the processing
report in the web browser. The application provides several different options for report generation. It
is either possible to append search results to a single, existing report file or create a separate report
file for each run. The difficulty with using a single report file is that it is necessary to scroll down to
the bottom of the report file in order to see the latest results. Using multiple report files can produce
many files depending on the frequence with which the operation is executed.

The report files consist of several sections:

- Report header: shows when and who executed the operation, and what software version was
used.

- Processing Summary: lists all statistics such as number of rules used, number of text matches
found, number of input files searched, and number of files copied. This section also lists a
brief description of all rules used by the run.
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- Processing details section: lists information separate for each rule. Each rule gets its own
section that provides all details such as rule description, input files processed by this specific
rule (files that matched the rule search settings), text matches (listing text, file and page
number) and most importantly list of files copied, including input and destionation paths.

AutoDocSearch Text Search Rep X

@ file:///C:/Users/Admin/DocL c Q_ Search

[B Most Visited & Getting Started

AutoDocSearch Text Search Report

¢ Processing Date : 05/10/17 07:37:30
¢ User Name : Admin

e Computer Name : OREGONPC

¢ Adobe Acrobat Version : 15.1536

¢ Software Build Date : Dec 15 2016

Processing Summary

o Total number of rules used for searching: 2

¢ Total number of text matches found: 7

o Total number of input files searched: 7

o Total number of files without any text matches: 0

e Total number of rules applied to files: 2

o Total number of times rules have been applied to files: 7
o Total number of files copied by the rules: 7 SHOWS RULES USED

Rules Summary

o Rule 1: (Find purchase order numbers), Search text: Order \d+, Number of matches: 3, Files applied to: 3, Files copied: 6
¢ Rule 2: (Find invoices and copy files to "invoice" folder), Search text: Invoice \d+, Number of matches: 4, Files applied to: 4, Files copied: 8

Processing Details
Rule 1 (Find purchase order nhumbers), Search text: Order \d+, Number of matches: 3

Files processed by the rule:

1. C:\Data\lnput\Purchase Order 83427498 .pdf
2. C:\Data\Input\PO 929211285 .pdf

3. C:\Data\Input\PO 66341285 pdf / SHOWS TEXT MATCHES

Text matches:

1. File: C:\Data\lnput\PO 66341285.pdf, Page: 1, Text found: Order 66341285
2. File: C:\Data\Input\PO 929211285.pdf, Page: 1, Text found: Order 929211285
3. File: C:\Data\lnput\Purchase Order 83427498.pdf, Page: 1, Text found: ORDER 83427498

SHOWS FILES COPIED
Files copied: /

1. File: C:\Data\lInput\PO 66341285.pdf Copied To: C:\Data\Orders\PO 66341285-Order (1).pdf
2. File: C:\Data\Input\PO 929211285.pdf Copied To: C:\Data\Orders\PO 929211285-Order (1).pdf
3. File: C:\Data\lnput\Purchase Order 83427498.pdf Copied To: C:\Data\Orders\Purchase Order 83427498-Order (1).pdf

The report file is in HTML format and can be viewed and printed by any web browser. There is also
an option available to generate a CSV (comma-separated values) version of the report file. CSV is a
widely used text-based data exchange format supported by most spreadsheet applications including
Microsoft Excel. It can be opened directly by Excel application. However, the CSV report has a
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different formatting than the regular HTML report to conform to a spreadsheet layout. It lists one
search result per row and provides text location and rule information for the text match.

REVIEWING OUTPUT FOLDERS

Now, lets inspect the content of the output folders as specified by the search rules. Three files have
been copied from the “Input” folder to the “Orders” folder while appending “-Orders” at the end of
the file name. These files have been copied because they have matched one of the processing rules.

Home Share View

© ~ 1 | » ThisPC » OS(C) » Data » Orders v ¢! Search Orders

P

\ . A
i Favorites Name
I Desktop ‘

Date modified Type

PO 66341285-Order.pdf
PO 929211285-Order.pdf
Purchase Order 83427498-Order.pdf

1/19/2017 9:16 AM
1/19/2017 9:16 AM
1/19/2017 4:51 AM

Adobe Acrobat Do...
Adobe Acrobat Do...
Adobe Acrobat Do...

14 Downloads

b
<» Recent places

[ ror |
(£
[ ror |
X
[ - |
X

1A This PC
Iy Desktop

I* Documents
3 items

v

The rest of the files have been copied to the “Invoice” folder per instructions by the “Invoices” rule.
File names have been modified by appending “-Invoice” to the file name. The file name modification
is part of the options provided by the rule and is fully customizable.

Home Share View

@ ~ T | » ThisPC » OS(C) » Data » Invoices v ¢ Search Invoices

P

I Documents A Name
|3 Downloads
1o Music

L Pictures

B Videos
205 ()

Doc 2321143-Invoice.pdf
Doc 2374843-Invoice.pdf
Doc 2997143-Invoice.pdf
Doc 4487133-Invoice.pdf

o
[£]
- |
Ed
- |
[+
o
[

@J Network
4 items

Date modified

1/19/2017 9:14 AM
1/19/2017 9:14 AM
1/19/2017 9:14 AM
1/19/2017 9:15 AM

Type

Adobe Acrobat Do...
Adobe Acrobat Do...
Adobe Acrobat Do...
Adobe Acrobat Do...
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Expression Meaning

0-9 and A-7 All alphabetic characters and digits match themselves literally in
regular expressions.

N 2=\ O[] These characters have special meaning. Precede any of these

0O . characters with \ if you want to include them literally.

N Match one or more occurrences of the previous term

N Match zero or more occurrences of the previous term

- Match zero or one occurrence of the previous term

\d Matches one digit

\d+ Matches one or more digits

\d2) Matches exactly 2 digits

\d(3,7} Matches 3 to 7 digits

\d? Matches zero or one digit.

W Matches a single “word” character. It can be a letter, digit or
underscore.

\s Matches a single “space” character. It can be a new line or blank
space symbol.

[ABCD] One character from a group of symbols inside [ ] brackets. It
matches either A,B,C or D.

(A-7] Matches one character from A to Z.

[A1357] Matches one character that is not listed inside [ ] brackets. It will
not match 1, 3, 5 or 7, but will match any other characters.

(USA|Canada|Mexico) Use | symbol to match alternatives. This expression will match
either USA, Canada or Mexico.

Sample regular expressions:

\d{3}-\d{2}-\d{4} — matches US social security number, such as 507-82-9866
\d{10} — matches 10 digits account number, such as 1209474398
[A-Z]{2}-\d{5} — two letters followed by the dash and 5 digits, such as ST-12345

Visit

for in-depth description of the regular expressions.
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