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AutoRedact™ Plug-in Legal Notice 
© 2006 EverMap Company, LLC. All rights reserved. 

AutoRedact™ User Guide for Windows® 

If this guide is distributed with software that includes an end-user agreement, this guide, as well 
as the software described in it, is furnished under license and may be used or copied only in 
accordance with the terms of such license. Except as permitted by any such license, no part of this 
guide may be reproduced, stored in a retrieval system, or transmitted, in any form or by any 
means, electronic, mechanical, recording, or otherwise, without the prior written permission of 
EverMap Company, LLC. Please note that the content in this guide is protected under copyright 
law even if it is not distributed with software that includes an end-user license agreement. The 
content of this guide is furnished for informational use only, is subject to change without notice, 
and should not be construed as a commitment by EverMap Company, LLC. EverMap Company, 
LLC assumes no responsibility or liability for any errors or inaccuracies that may appear in the 
informational content contained in this guide.  

Please remember that existing artwork or images that you may want to include in your project 
may be protected under copyright law. The unauthorized incorporation of such material into your 
new work could be a violation of the rights of the copyright owner. Please be sure to obtain any 
permission required from the copyright owner. 

Any references to company names in sample templates are for demonstration purposes only and 
are not intended to refer to any actual organization. 

NO WARRANTY ON LICENSED SOFTWARE 

The Licensed software is provided to Licensee “AS IS”. EverMap Company, LLC makes no 
warranty as to its use or performance. In no event will EverMap Company, LLC be liable to 
licensee for any damages, claims, or costs whatsoever, or for any consequential, indirect, 
incidental damages or any lost profits or lost savings, even if representative of EverMap 
Company, LLC has been advised of the possibility of such loss, damages, claims, or costs. The 
aggregate liability of EverMap Company, LLC shall be limited to the amount paid for the 
licensed software, if any. 

Notice to U.S. Government End Users. The Software and Documentation are "Commercial 
Items," as that term is defined at 48 C.F.R. §2.101, consisting of "Commercial Computer 
Software" and "Commercial Computer Software Documentation," as such terms are used in 48 
C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 
C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and 
Commercial Computer Software Documentation are being licensed to U.S. Government end users 
(a) only as Commercial Items and (b) with only those rights as are granted to all other end users 
pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright 
laws of the United States.  

EverMap Company, LLC, 6370 NW Fair Oaks Dr., Corvallis, OR, 97330, USA. 
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Introduction to AutoRedact™ Software 
What is Redacting? 
 
The definition of redaction is to remove certain types of information from documents. In 
the context of United States government agency documents, redaction generally refers 
more specifically to the process of removing sensitive information from a document prior 
to its publication, during declassification. For attorneys, redacting is a very important 
process of protecting confidential information. During case discovery, a document must 
be distributed containing sensitive information and it is important to redact all non-
discoverable confidential material in that document before it’s release. The Freedom of 
Information Act (FOIA) and Privacy Act of 1974 grant people the rights to access 
government records, however, each laws defines a list of exemptions that allow agencies 
to exclude certain type of information from the public documents. Most of the federal and 
state agencies (many states also have their own freedom of information laws) have to 
redact documents before releasing them to public. There are cases when failing to 
properly redact electronic documents will result in serious consequences such as legal 
charges. As numerous people have learned to their chagrin, merely covering up the text 
and images in PDF documents is not enough – information has to be completely removed 
from the document. The US Congress and many government agencies including the 
Department of Homeland Security have recognized the importance of proper redacting 
techniques and have taken measures to make sure that critical information is not 
accidentally disclosed. National Security Agency (NSA) has published a special report 
devoted entirely to safe methods for redacting of electronic documents. The use of proper 
redacting software is becoming increasingly important as more government agencies 
release information in the electronic form. This calls for automated software that can 
increase productivity while providing safe methods for information redaction.  

What is AutoRedact™ Plug-in? 
 
AutoRedact™ plug-in is an add-on to Adobe Acrobat® and Adobe Acrobat® 
Professional® software that provide a complete set of tools for safely redacting various 
type of information from PDF documents. AutoRedact™ deletes sensitive text and image 
information from PDF documents making them completely safe for distribution. The 
software contains many powerful operations and tools that increase productivity and 
provide powerful methods for automated document redacting. 

Introduction to Redacting PDF Documents 
 
In the modern age of digital documents and internet, many federal, state and local filings 
can be made electronically. According to latest statistics approximately 300 government 
agencies, including courts, have adopted or recommend PDF as a standard electronic 
document format. This means that documents must be submitted in PDF or required to be 
distributed in PDF format. Redacting PDF documents becomes an important and critical 
step in document processing and distribution workflow.  Adobe Portable Document 
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(PDF) is complex, sophisticated computer data format. It supports many kinds of 
information such as text, graphics, tables, images and meta-data integrated into a single 
document. This complexity makes it easy to expose information unintentionally. 
Covering text, charts, tables, or diagrams with black rectangles, or highlighting text in 
black, is a common and effective means of redaction for hardcopy printed materials. It is 
not effective, in general, for computer documents distributed across computer networks. 
The most common mistake is covering text with black rectangles. The important issue to 
understand is that the information hidden or covered in a PDF document can almost 
always be recovered. The way to avoid exposure is to ensure that sensitive information is 
not just visually hidden but is actually removed from the original document. PDF 
documents are complex files that can contain variety of information composed in many 
different ways. Many mistakes can occur inadvertently in document composition or 
during file format conversions. For example, sensitive information in an embedded image 
can be overlaid with another image during format or text elements can be located behind 
images as a result of optical character recognition process. Such hidden data can be 
difficult to be spot during manual review. Specialized redacting tools can greatly simplify 
document redacting process and provide a much higher degree of safety and reliability. 
 
PDF documents may contain several different kinds of information that call for various 
techniques for removal of confidential data from the document. The most common type 
of information stored in PDF documents is text. This is the most convenient type of 
information for redacting purposes, because text can be quickly searched and easily 
removed from PDF documents. However, there are vast amount of PDF documents that 
are created by document scanning and originally do not contain any searchable text. 
These documents are merely collections of scanned images and can’t be efficiently 
searched for occurrence of specific text or pattern. It’s possible to run a “paper capture” 
or optical character recognition (OCR) processing on such documents to find all 
occurrences of text and add searchable text elements to the document. Text is added 
behind the images preserving the original look of the scanned document. Adobe 
Acrobat® comes with built-in tools for this type of processing. Depending on the Acrobat 
version it’s either called “Paper Capture” or OCR. PDF documents can often contain 
drawings, charts or graphics that are neither images nor text elements. This type of 
information is much more difficult to redact. It is necessary to convert pages that contain 
such drawings to images first. AutoRedact™ plug-in provides a special conversion 
operation (“Plug-ins > Redacting > Advanced > Convert Page Content To 
Image”) that converts the content of the page(s) (including drawings, images and text) to 
a single image and deletes all other types of information. This allows to safely redact 
such pages as images and completely remove information from the PDF document. 
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Functionality Overview 
 
AutoRedact™ plug-in offers a complete set of tools and operations for preparing 
documents for redaction, redacting documents and maintaining document processing 
logs. Software features the following capabilities: 
 

• Find and mark text for redacting from user-defined redacting dictionaries. 
Redacting dictionary is a collection of words and phrases that need to be removed 
from documents. Software provides a built-in editor for creating, editing, 
searching and importing redacting dictionaries. 

• Find and mark up for redacting various text patterns such as social security and 
employer identification numbers, phone and fax numbers, email addresses, postal 
addresses, dates, text between brackets and etc. 

• Find and mark up for redacting custom text patterns (using powerful regular 
expressions or just by simply typing the text you are looking for).  

• Manually mark up text and images for redacting using easy-to-use redacting tool. 
Just draw a rectangle around the area on the page that need to be redacted. 
Desired exemption codes are automatically assigned to redacting areas. 

• Mark up page content located at specific positions on the page (templates). Save 
and re-use multi-page templates for quick document processing. 

• Automatically find and markup all text and/or images in the document for 
redacting. 

• Use Acrobat’s standard commenting and markup tools to select page content for 
redacting. AutoRedact™ works directly with many standard annotations types 
allowing other members of your team without AutoRedact™ software can also 
efficiently prepare documents for redacting by using standard Acrobat® 
annotations types such as highlight, strikeout, underline or rectangle to indicate 
areas on the page for redacting. No special conversion is required. 

• Assign exemption codes to redacting areas. Exemption codes can be optionally 
printed on the page to indicate why this particular information was removed. 

• AutoRedact™ comes with several common exemption code groups such as 
Freedom of Information Act (FOIA), Privacy Act and case discovery.  

• Employ easy-to-use built-in editor to create and maintain unlimited custom 
exemption codes. 

• Easily navigate, search, edit, review and print redacting annotations using 
standard Acrobat tools for annotations. AutoRedact™ works with standard 
annotations types to utilize powerful features already available in Adobe 
Acrobat® software.  

• Safely redact text and images from documents. Redacted text is replaced with 
optional “redacting” character or with a blank space. Many different options 
available to control the appearance of the redacted document. 

• Add exemption codes and color bars to redacted areas. Software provides fine 
control over font style, size, text, line and filling colors.  

• Print documents with redacting annotations. 

 
AutoRedact™ User’s Guide  8 



www.evermap.com  EverMap Company, LLC. 
 

• Automatically convert page content to image. 
• Remove all types of annotations from documents. 
• Remove all embedded file attachments from documents.  
• Export document’s text to external text file for verification and record keeping. 
• AutoRedact™ maintains a complete log file for each processed document to 

record all information about all stages of the redacting process. Log files are 
maintained as hyperlinked HTML files for easy navigation. 

• AutoRedact™ provides complete support for Acrobat batch processing 
framework. Most redacting operations are implemented as Acrobat’s batch 
commands allowing creation of powerful batch sequence for automatic document 
processing. 

• Software provides fine level of control over most types of processing. Any 
operation can be performed on the whole document or just on a range of pages. 

• Redacting can be performed either on the documents itself or on automatically 
created copies. 

System Requirements and Compatibility 
 
AutoRedact™ plug-in requires Adobe® Acrobat® or Adobe® Acrobat Professional® 
software installed on your system. Plug-in works with full versions 5.0, 6.0 and 7.0.  
 
Batch processing commands are only available in Adobe® Acrobat Professional® 
(versions 6.0 and 7.0) or Adobe® Acrobat® version 5.0. 
 
Operating system requirements: Microsoft Windows XP/NT/2000/2003 
 
IMPORTANT: This plug-in will not work with the free Adobe® Acrobat® Reader. 
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Getting Started 
 

Installing AutoRedact™ Plug-in 
 
Download and start product installation software from http://www.evermap.com or insert 
the AutoRedact CD in your CD drive. Follow on-screen instructions to finish installing 
AutoRedact™ plug-in. Software requires presence of the Adobe Acrobat® on your 
computer. 
The installation program automatically determines the path to the latest version of 
Adobe® Acrobat® software that is installed on your computer. The plug-in will be 
installed to the "plug-ins" folder of the Adobe® Acrobat® application (standard location 
for all Acrobat plug-ins). If there are multiple versions of Adobe® Acrobat® on your 
computer, the plug-in would be installed in the most recent version of the Adobe® 
Acrobat® software. 
 
The full path to the plug-in is: < Adobe Acrobat Installation Path>\ plug_ins\ 
AutoRedact\  
 
Typically, Adobe® Acrobat® is installed to the following location (assuming version 
7.0): c:\Program Files\Adobe\Acrobat 7.0\Acrobat\ 
 
IMPORTANT: Make sure that Adobe® Acrobat® is not running during the installation. 
 
Once the plug-in is installed it should add the following menu item to Adobe® Acrobat® 
menu: "Plug-ins > Redacting > ...". 
 

Starting AutoRedact™ 
 
To start working with AutoRedact™, launch Adobe Acrobat® and open a PDF document 
you want to work on by selecting “File > Open…” from the main Acrobat menu. All 
functionality of the AutoRedact™ plug-in is available from the “"Plug-ins > Redacting 
> ..." menu. Batch processing functionality is available through Acrobat’s batch 
processing framework dialog that is accessible through “Advanced > Batch 
Processing…” menu. Note that batch processing framework is part of Adobe Acrobat® 
Professional® software and is not available in Adobe Acrobat® standard package. 
 

 
AutoRedact™ User’s Guide  10 

http://www.evermap.com/


www.evermap.com  EverMap Company, LLC. 
 

 
 

Application Menu and Toolbars 
 
AutoRedact™ plug-in adds several user interface elements to the standard Adobe 
Acrobat® or Adobe Acrobat® Professional® software: “Redacting” menu, toolbar, and a 
redacting tool. “Redacting” menu is available as “Plug-ins > Redacting…” from the 
main Acrobat application menu: 
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Redacting toolbar is automatically added to Acrobat’s toolbar panel and initially appears 
as a dropdown menu. It can be expanded and moved to any location on the screen for 
convenient access. Toolbar is docked by default to main Acrobat toolbar panel. Redacting 
toolbar provides quick access to several most often used redacting functions.  
 

 
 
Redacting toolbar can be turned ON or OFF by using “View > Toolbars > Redacting“ 
menu option. Use this menu to turn toolbar back on if you accidentally closed this free-
floating toolbar.  
 
AutoRedact™ plug-in also displays “Redacting Tool – Exemption Codes” toolbar 
when “Plug-ins > Redacting > Draw Redacting Areas…” operation is selected from 
the menu. 
 

 
 
This toolbar is only visible when working with the “Draw Redacting Areas” tool. It 
automatically disappears when other Acrobat tools (such as “Hand” or “Select” tools) 
are activated. The exemption code selection that is available from this toolbar determines 
the exemption code that is assigned to all new redacting annotations created with this 
tool. 
 
AutoRedact™ plug-in ads “Help > Plug-in Help > AutoRedact…” menu that displays 
AutoRedact™ user’s guide. This menu performs the same action as “Plug-ins > 
Redacting > How To… Redact Documents” menu item. 
 
AutoRedact™ plug-in ads “Help > About Third-Party Plug-ins > AutoRedact…” 
menu that displays application’s “About” dialog. 
 
AutoRedact™ plug-ins installs a list of batch processing commands to the Adobe 
Acrobat® Professional® batch processing frameworks. See “Batch Processing” section 
for more details about using redacting commands.
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Redacting Workflow Overview 
Introduction  
 
Document redacting is typically performed in several stages. Every organization might 
have their own redacting workflow; however there is a common sequence of operations 
that most of them will share. 
 

Mark up text and 
areas on the pages 

that need to be 
redacted using 

AutoRedact tools 

Redact marked 
content using 

“Redact Marked 
Content” operation 

Review the results and 
remove all 

annotations, apply 
security settings, save 

the document  

Inspect and prepare PDF 
document for redacting 

by performing all 
necessary conversions. 

START 

END 

 
 

Step-by-Step Overview 
 

1. Receive and inspect original PDF document that is going to be redacted. 
 
2. Make a backup copy of the document for archival purposes. 

 
3. Open a document in Adobe Acrobat and determine what kind of elements it 

contains. Does it contains searchable text only or were some pages produced by a 
document scanning process and contain just images? Does your document contain 
any drawings that are not images? Identify types of information you want to 
redact: is it text, images and/or drawings? 

 
4. Based on your evaluation of the document, perform all necessary preprocessing 

that might include: running optical character recognition (OCR / “Paper 
Capture”), flattening forms, and converting pages with drawings to images. 

 
5. Specify desired preferences for text markup and redacting.  
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6. Use redacting tools and operations to mark up text and areas in the document that 

need to be redacted. The selection of methods depends on the type of information 
you need to redact. For example, if all dates need to be removed then use “Mark 
Up Text Patterns” operation. If you know a list of specific words or sentences 
that need to be redacted then the logical choice is to use “Mark Up Words from 
Dictionary”, etc. Use “Draw Redacting Areas” tool to manually define areas 
in the document that need to be redacted. Use “Mark Up Text With Template” 
to add redacting areas to the documents using a redacting template. 

 
7. Review the resulting document and verify that all occurrences of confidential 

information are properly marked and have correct exemption codes assigned.  
 
8. Run redacting operation by selecting “Redact Marked Content” from the 

redacting menu. This operation will actually remove text and alter content of the 
images. Depending on the preferences, redacting will be performed on the copy of 
the original document or on the document itself.  

 
9. Inspect the redacted version of the document and make sure that all confidential 

information has been removed. Export document content to a text file to verify 
that no confidential text is present in the document. 

 
10. Remove all annotations from the document (optional). AutoRedact™ plug-in can 

automatically remove annotations after they have been successfully used for 
redacting. 

 
11. Optionally password protect document from modifications, digitally sign and save 

to a desired filename. 

Appearance of the Redacted Documents 
 
The final appearance of the redacted document depends on combination of AutoRedact™ 
preferences that control visual aspects of the redacting process. AutoRedact™ software 
provides an option for specifying a redacting character used to replace all redacted 
characters in the document. This can be any printable character or a blank space (default). 
Exemption codes can be optionally printed in the upper left corner (adjustable) of each 
redacted area. Font style, size and color as well as offsets can be customized to provide 
users a way to customize the final product according to their needs. AutoRedact™ plug-
in can optionally mark redacting areas in the document as color bars or transparent 
rectangles. This option provides a powerful ability to visually indicated areas on the page 
where redacting has been applied. User can choose fill and line colors of the redacting 
boxes to create a desired look and feel of the redacted documents. This functionality 
provides a way to make redacting areas stand out from the rest of the page content and 
create appearance of the professionally redacted document. The snapshot below 
illustrates few combinations of these parameters and resulting appearance of the redacted 
document: 
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Note that color bars that can be optionally added by AutoRedact™ software serve only a 
cosmetic purpose; they do not cover text elements because text element have already 
been removed from the document by the redacting process. Color bars become a part of 
the document’s content and will always be printed and displayed with the rest of the 
document’s content. The snapshot below shows “before and after” appearances of the 
redacted image in the document. The “before” picture on the left shows a redacting 
annotation around a portion of the image. The “after” picture shows a black rectangle 
embedded into the image by AutoRedact™ that removes all image pixels in the redacted 
area.  
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Preparing Documents for Redacting 

Introduction 
 
It is often necessary to inspect PDF document before starting the redacting process and to 
determine if any additional pre-processing is necessary. This may include running various 
conversion operations on the document’s content to prepare it for the redacting markup. 
Once all necessary conversions are completed it is recommended to set the preferences 
for markup and redacting. They determine the way the document is processed and define 
visual appearance and content of the redacting markup. 

Examining Document Content 
 
Examine the content of the document you are working on and determine the type of 
information that needs to be redacted. Is it text, images or drawings? Text is the easiest 
type of information for redacting, because it can be quickly searched for occurrences of a 
specific string or pattern. There are multiple methods that can be used to determine the 
type of visual elements in the PDF documents. The most reliable method for inspecting 
page content is to use the “Content” navigation tab: 
 

 
 

1. Open a document (“File > Open…”) and navigate to page you want to inspect. 
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2. Select “View > Navigation Tabs > Content” from the menu. “Content” dialog 
will be displayed on the screen. 

3. Select desired page number in the page tree view and expand it.  
4. Page tree view displays a hierarchical view of the page. Right click on any entry 

and select “Highlight Content” option from the popup menu. 
5. Click on any entry in the page tree and corresponding page object will be 

automatically highlighted with a blue rectangle in the document view. 
6. Using this dual view of the page you can inspect what object types are present on 

the pages. Searchable text appears as “Text” entries, raster images typically 
appear as “XObject: Image” entries. Graphic (Postscript) elements appear as 
“Path” elements.  

 
Depending on the page element content you may need to perform a preprocessing step 
that might include running an optical character recognition (OCR or “Paper Capture”) on 
the document to convert text in the scanned images to searchable text elements. Many 
documents are created by scanning paper documents with an optical scanner. This 
process produces PDF documents that consist of image elements only. What visually may 
appear as a legitimate text is actually just an image.. The obvious downside of this is that 
you can not search such document for occurrence of a specific text. If you are working 
with such documents and need a capability to search and mark for redacting a specific 
word or phrase then you need to convert images to text first. However, you may not need 
to perform such conversion if information that you want to redact can be easily removed 
as a part of the image.  
 
OCR functionality can be accessed via the following menu entries: 
 
In version 7.0: “Document > Recognize Text Using OCR > Start…” 
In version 6.0: “Document > Paper Capture > Start Capture…” 
 
Image to text conversion quality is getting better every year, however it’s always strongly 
recommended to inspect the results of OCR to ensure accuracy of the conversion. You 
can run processing on the entire document or just on the selected range of pages. Save a 
copy of the document once you completed OCR processing. You will not notice any 
difference in visual appearance of the document before and after running OCR 
processing, however it will make the document searchable. Try to search your document 
for appearance of some test words or phrases to make sure the document is processed 
correctly. 
 
Documents may contain drawings or graphics that are not raster images, but rather are 
vector (Postscript) graphics. This type of elements appears as “Path” entries in the page 
tree view of “Content” navigation tab. AutoRedact™ can’t directly redact these PDF 
elements. You have to convert “Path” elements into an image before performing the 
actual redacting. AutoRedact™ provides a special operation that converts all content of 
one or more pages to a single image.  
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Select “Plug-ins > Redacting > Advanced > Convert Page Content To Image…” 
from the menu to convert pages that contain drawings that need to be redacted to images. 
 

 
 
Select a range of pages that need to be converted to images. Content of each page will be 
replaced with a single image and all other kinds of elements will be deleted. The output 
image resolution greatly affects the quality and appearance of the resulting image. Image 
resolution can be adjusted from 150 dpi (low-quality) to 600 dpi (high-quality). Note that 
the quality and resolution of the image comes with significantly increased file size that is 
needed to represent more information. This conversion operation creates black and white 
image and will change appearance of the color graphics and color and grayscale images. 
 
To adjust image resolution for the conversion process click on “Edit Preferences…” 
button. Adjust “Graphics to image conversion resolution” to a desired value and close the 
document. You have to do it once only, since AutoRedact™ will remember this 
preference for the next time.  

Selecting Redacting Preferences 
 
It is recommended that you select AutoRedact™ preferences before you start marking up 
document content for redacting. These settings affect various aspects of the redacting 
process: from text search to visual appearance of redacting annotations.  
 
Select “Plug-ins > Redacting > Preferences…” from the menu to open “Redacting 
Preferences” dialog. This dialog consists of 5 different tabs:  
 
“General” tab contains settings that affect general behavior of the AutoRedact™. 
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“Markup” tab provides controls over visual appearance of the redacting markup. 
“Redacting” tab controls visual appearance of the final redacted document. 
“Dictionaries” tab provides tools for managing redacting dictionaries. 
“Exemption Codes” tab provides access to exemption codes editor. 

General Preferences 
 
“General” tab offers the following options: 
 

 
 

1. “Create a new document for redacting output (do not change the 
original)” option controls redacting target. If this option is “on” then 
AutoRedact™ will automatically create a temporary copy of the current document 
and perform redacting on it instead of the original document. If this option is 
“off” then redacting will be performing directly on the currently opened 
document. This option is ignored in the batch processing framework because of 
the way batch processing works. Batch processing always performs redacting 
directly on the input document. You can one of the batch processing commands to 
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create a copy of the input file and apply redacting to it without changing an 
original. 

 
2. “Remove redacting annotations if they have been used during redacting” 

option automatically deletes a redacting annotation if it has been used while 
redacting. This is a convenient function that provides immediate feedback on the 
results of the redacting process.  

 
3. “Output log files for each processed document” option enables automatic 

redacting log maintenance for each processed document. Log files keep records of 
all redacting and markup operations (except manual markup) performed on the 
document. See “Redacting Logs” section for more details about working with 
redacting log files. 

 
4. “Do not allow redacting without exemption codes” option prevents redacting 

for the redacting annotation that has no exemption code assigned. This option is 
helpful when it’s necessary to ensure that each redacting occurrence is 
accompanied by a corresponding exemption code. 

 
5. “Process text in order it appears in PDF document” affects the order in 

which the text is processed in the document. This option has no effect on many 
documents, but it affects few special cases when text on the page is not stored in 
the top-to-bottom order. This especially applies to multicolumn pages that may 
have complex text layout.  

Markup Preferences 
 
“Markup” tab contains options that control visual appearance of the redacting 
annotations as well as text processing options. 

 
1. “Annotation style for word markup” option defines annotation style used to 

mark up text during the following operations:  
 

• “Mark Up Text From Dictionary”,  
• “Mark Up Text Pattern”, 

 
Select one from the four available annotations styles: “Highlight”, “Cross-Out”, 
“Underline”, and “Rectangle”. This option only affects visual appearance of the 
text markup and has no other effect. Select annotation style that better suits your 
project. “Highlight” annotation is selected by default. Typically, it provides a good 
visibility for marked content while “Rectangle” annotation can provide the minimal 
appearance. It’s suggested to select “Rectangle” annotation when you expect that a 
large portion of the page will be selected for redacting.  
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The following operations are not affected by this selection and always use 
“Rectangle” style to create annotations: 

 
• “Draw Redacting Areas” 
• “Mark Up All Text” 
• “Mark Up All Images” 

 
“Mark Up With Template” operation uses annotation styles that have been saved to a 
template. It provides an ability to mix different annotation types within a single page or 
template and is not affected by this option. See “Marking Up Content with Templates” 
section for more details about creating and using redacting templates. 
 

 
 

2. “Markup color” combo box controls the drawing color of all redacting 
annotations created by the following operations: 

 
• “Mark Up Text From Dictionary”  
• “Mark Up Text Pattern” 
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• “Draw Redacting Areas” 
• “Mark Up All Text” 
• “Mark Up All Images” 

 
3. “Annotation border width” affects appearance of border thickness for 
“Rectangle” annotations. Thicker border makes annotation more visible on the page 
and improves readability of the document for review and further markup. Border 
thickness is specified in points (1 point equals to 1/72 inch). 
 
4. “Annotation “Subject” text” is used to label markup annotations. It is used to 
display annotation “Subject” text. The subject text is by default set to “Redacting”. 
Annotation “subject” is displayed in Acrobat’s “Comments” navigation tab (when 
individual annotation entry is expanded). It has no particular meaning and can be used 
at user’s discretion to indicate various types of information. The snapshot below 
shows the “Comments” tab with redacting annotation (Use “View > Navigation 
Tabs > Comments” or “Plug-ins > Redacting > Show / Hide Navigation” to 
show or hide this tab). The “Comments” navigation tab provides many useful tools 
for reviewing, editing and navigation annotations in the document. 
 

 
 
6. “Perform text matching across multiple text lines (ignore line breaks)” 

option affects how AutoRedact™ performs text search. If this option is selected 
then software can match text that starts on one line and ends on another. For 
example, suppose the page contains the following text: 

 
The quick brown  
fox jumps over the lazy dog. 
 
When searching for a “brown fox” string, software will successfully find and 
mark this text on the page. If this option is turned off then each text line on the 
page is searched separately and software will not detect this particular occurrence 
of the “brown fox” string. Turning this option off is useful when searching text 
pages that contain lists of items that occupy just a single text line, to prevent 
matching across several logically separate text units. 
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7. “Do not create overlapping annotations” option prevents creation of duplicate 

or overlapping annotations. Sometimes it’s necessary to run several different 
operations to search and markup the text. This can produce duplicate annotations 
that are useless for the redacting process.  

Redacting Preferences 
 
“Redacting” tab contains options and settings that control visual appearance of the final 
redacted document and processing logic of the redacting operation. 
 

 
 
“Redacting Settings”: 
 

1. “Redacting character” is used to replace characters in the redacted text when 
removing information. Enter any single, printable character, which could be blank 
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space. Check “Use blank space character” option to automatically use “blank 
space” character. 

 
2. “Redact only if character:” menu provides fine control over redacting logic. 

AutoRedact™ software evaluates bounding box of each character that overlaps a 
redacting annotation and makes a decision to redact it only if the overlap 
condition satisfies the selected option. There are three possible options available: 

 
• “Overlaps at least 25%” (default) 
• “Completely inside redacting box” 
• “Touches a redacting box” 

 
Bounding box of any character is slightly larger than the visual appearance of it. 
This is why “Completely inside redacting box” or “Touches a redacting 
box” options may not produce expected results when manually drawing a 
redacting annotation. It is relatively easy to draw a slightly larger or smaller box. 
This is why “Overlaps at least 25%” option is the most reliable and safest one. 
It corresponds very well with human visual perception and always produces 
expected results. However, depending on particular situation it might be necessary 
to use two other options. 

 
3. “Fill redacted images with:” menu option allows selecting a color used for 

redacting an image. The area on the image covered by a redacting annotation will 
be filled with the selected color to remove information. There are only two 
options available – “white” or “black”. However, actual color depends on the 
image type and bit-depth. Certain images may not have the selected color 
available in their color palette. In this case redacting area may appear differently 
depending on available colors. 

 
4. “Redact content of the text form fields” option enables redacting of text fields 

in Acrobat forms.  A PDF form can contain static or interactive form fields; 
interactive form fields let the user fill in the form using his or her computer. Text 
fields can be set up to accept user input, to display text strings, and to allow 
multiple lines of text. Text fields are dynamic and interactive fields different from 
the regular text elements. AutoRedact™ always redacts all characters in the text 
field. It is not possible to redact only portion of text field’s content. The 
appearance of the redacted text field may vary depending on your version of 
Adobe Acrobat. Another way to redact all form fields from the document is to use 
“Remove All Annotations” operation that will completely remove form fields 
from the document. 

 
Check “Add exemption codes to the redacting areas in output document” option to 
automatically add exemption codes associated with redacting annotations to the redacted 
document. You have control over font style, size and color.  
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 “Offset from top-left corner of the box (X, Y)” determines where to place exemption 
code text (relatively to the redacting annotation). Text offset is specified in points (1 
point equals to 1/72 inch). 
 

 
 
“Redacted Areas Appearance” Settings 
 

1. Check “Stroke redacted areas with this color:” option to select a draw a 
border around each redacting area. Select a desired color from a pull-down menu. 

 
2. Check “Fill redacted areas with this color:” option to fill redacted areas with a 

specific color. This will create an appearance of the redacting color or “black” 
bar. Use this option to create a traditional appearance of the censored text. 

 
The snapshot below illustrates appearance of the redacted document where the redacted 
area is stroked with red and filled with dark gray. Exemption code is added (in white) on 
the top of the redacting bar. 
 

 
 
IMPORTANT: Please note that redacting bars are used for visualization purpose only, 
there is no text hidden behind it. Text has been already redacted from the document 
before adding the bars. You can not use AutoRedact™ bars to cover the information – 
this practice is considered unsafe and is not supported by the software. This feature is 
used to improve visibility of the redacted areas in the output documents and give it a 
traditional appearance of a censored text that is easily recognized by most people. 
 
It’s not necessary to select a redacting character if you are planning to add color bars to 
the redacted document. Redacting bar will cover the redacting characters and make it 
invisible anyway. Select light gray color for redacting bars in order to use less toner or 
ink when printing documents with many redacted areas. 
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Marking Up Text Using Dictionaries 

Introduction 
 
AutoRedact™ plug-in supports a powerful ability to simultaneously search text in PDF 
document for all occurrences of user-specified words and phrases. This process is very 
fast when compared to individually searching and highlighting of individual text strings. 
It provides a tremendous power while redacting documents using user-defined collections 
of text strings. AutoRedact™ calls such collection a “Redacting Dictionary”.  Software 
can quickly scan the document and mark all occurrences of the redacting text with an 
annotation. AutoRedact™ utilizes four commenting and markup annotations standard in 
Acrobat: highlight, strikeout, underline and rectangle. User can select annotation type 
and visual appearance that will be used for markup. Different styles and colors can be 
used by different members of the team or to indicate particular exemption code or any 
other type of information. Once text has been marked it can be effectively redacted from 
document by applying “Redacting” operation. The acual operation of redacting is very 
fast and simple, so obviously the hardest part is to prepare the document for redacting by 
creating annotations indicating which information to remove.  

What Is a Redacting Dictionary? 
 
The redacting dictionary is a collection of individual redacting entries. Each entry 
consists of redacting text and an optional exemption code. Redacting text represents 
any sequence of characters to be found in the document and marked for redacting. Each 
redacting text entry is unique within the dictionary. All duplicate entries are 
automatically discarded. Exemption code is a special sequence that is placed on the page 
at the location of the redacted information to indicate the reason why that particular piece 
of information had been withheld. Exemption code can be optionally put on the page in 
place of the redacted text during the redacting operation. It’s not necessary to assign an 
exemption code to the redacting text; this field can be left blank or assigned at any time. 
However, it is not possible to create entries without a redacting text. All such entries will 
be discarded. AutoRedact™ uses redacting text to search the document and mark up all 
of it occurrences for redacting. Software automatically creates a redacting (commenting) 
annotation for located text and adds an exemption code as a note or a comment with the 
annotation. Visual appearance and type of annotations used depend on the user 
preferences selected in the “Markup” tab page in the “Redacting Preferences” dialog 
box. 
 
AutoRedact™ maintains a local repository of redacting dictionaries on the user’s 
computer. It’s possible to have about 16,000 different dictionaries on a single computer 
installation. However, it is rarely necessary to have more than a few. All redacting 
dictionaries are stored in the AutoRedact™ installation folder in a file called 
AutoRedactDictLocal.CFS. You can copy this file between computers to transfer 
redacting dictionaries between different users.
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Managing Redacting Dictionaries 
 
Redacting dictionaries are collections of words and phrases that need to be redacted from 
documents. The content of the redacting dictionary is typically user-specific and is often 
used on the regular basis to redact many similar documents. AutoRedact™ software 
provides a set of tools for creating, editing and managing redacting dictionaries.  
First you need to create a redacting dictionary before you can start searching your 
documents for occurrences of a particular string. Redacting dictionaries can be accessed 
from “Redacting Preferences” dialog: 
 

1. Select “Plug-ins > Redacting > Preferences…” from the main menu or click 
on the “Preferences” button on “Redacting” toolbar. 

 

 
 
2. Select “Dictionaries” tab in the “Redacting Preferences” dialog. All available 

dictionaries will be displayed in the “Available Redacting Dictionaries” list. 
Each entry in the list displays a dictionary name and a description. There is only 
one “Sample” dictionary in this list after initial installation of the AutoRedact™ 
plug-in. This dictionary is provided for learning purposes only and provides an 
example of the possible redacting dictionary content. 
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3. Click “Create New…” button to create a new redacting dictionary. “Edit 
Redacting Dictionary” will appear on the screen. This is the main dialog box 
for creating and editing redacting dictionaries. It allows you to specify dictionary 
name with description and add, edit, delete, import, export or print entries.  

4. Select an existing redacting dictionary in the list and Click “Edit…” button to 
edit the dictionary.  “Edit Redacting Dictionary” will appear on the screen 
allowing you to edit all the information in the dictionary. You can also double-
click on the name of the redacting dictionary from the list to edit the dictionary. It 
has the same effect as selecting the dictionary and clicking the “Edit…” button. 

5. Select an existing redacting dictionary in the list and Click “Delete…” button to 
permanently remove this dictionary from the repository. You will be asked for 
confirmation when deleting a dictionary. 

 
Warning: A redacting dictionary can not be recovered once it has been deleted. All 
of its contents will be lost. 
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Creating and Editing Redacting Dictionary 
 
“Editing Redacting Dictionary” dialog box provides tools for adding, editing, 
importing, exporting and printing of redacting text entries.  
 

 
 
Enter dictionary name and description once you’ve created a new dictionary. It’s a good 
idea to provide a short unique name and a longer description. This will help you to 
identify this dictionary later. You can change dictionary name and description at any 
time. There is no need to use unique names, although it helps to better organize your 
collection. 
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Click in the “Redacting Text” column to enter new or edit existing text. The redacting 
entries table works very similar to a spreadsheet. Use “Tab” button to quickly move 
between entries.  
 
Click “Add More Rows” button to add more blank records to the redacting dictionary.  
You can remove all entries in the dictionary by clicking on the “Remove All” button. 

Assigning Exemption Codes To Dictionary Entries 
 
There are typically very few different exemption codes used compared to the number of 
redacting entries. In such case it is convenient to assign the same exemption code to 
multiple entries simultaneously. In order to do that, select multiple rows by first clicking 
on the first entry and then on the last entry while holding a “Shift” key on the keyboard. 
This will select all entries starting from first and last entries clicked. You can add or 
remove entries from selection by clicking on the entry (click inside “Exemption code” 
or “Redacting Text” columns) while holding down the “Ctrl” key on the keyboard. 
Click on the “Assign Exemption Code To Selected Rows…” button once you are 
satisfied with your selection. This will open an “Exemption Code” dialog box that will 
let you assign a single code to all selected entries. 
 

 
 
Enter desired code into the “Code” entry box and click “OK” button to confirm the 
change. The specified exemption code will be assigned to all selected entries. 

Importing and Exporting Redacting Dictionaries 
 
If redacting text is available in the electronic form, it may be convenient to import it into 
AutoRedact™ dictionary directly. Format the input ASCII text file to contain one line per 
redacting word or sentence. Click “Import From Text” button and select this file for 
import. AutoRedact™ will automatically add each line from this file as a separate 
redacting entry. Each line in the ASCII file will be treated as a redacting entry, and 
corresponding exemption codes will be left blank. You can assign exemption codes to 
imported entries using the method described in the “Assigning Exemption Codes” 
section. 
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Redacting text can be exported to ASCII text file by clicking on “Save As Text…” 
button. Output text file will contain one redacting entry (redacting text only, no 
exemption code) per line. 

Finding Entries in a Redacting Dictionary 
 
Sometimes it’s necessary to edit or remove a specific redacting text. Finding a particular 
entry in a large dictionary can be a difficult task. AutoRedact™ provides a way to 
quickly search redacting dictionary and find all occurrences of the specified text. Enter 
text you want to search for into “Find what:” entry box. Click “Find Next” or “Find 
Prev” button to start searching. If the search is successful, a corresponding entry will be 
highlighted and made visible on the screen. Otherwise, you’ll see a “Can’t find string” 
message pop up. Software performs case-insensitive search: it will find all occurrences of 
the specified text regardless of the case. Check “Match whole entry” option to find all 
entries that completely match a search string. This option will skip all partial matches and 
find only those redacting text entries that contain exactly the same text. For example, 
when searching for a word “Wesson”, it will skip all partial matches such as “Wesson 
Jr.” or “Smith-Wesson”. 

Printing a Redacting Dictionary 
 
Redacting dictionary can be printed to any installed printer. Click “Print…” button to 
select a printer and print redacting dictionary content. Both exemption codes and 
redacting text will be printed. Another way to print a redacting dictionary is to export it to 
the ASCII text file and use any existing text editor to format and print the text. 

Marking Up Text with a Redacting Dictionary 
 
1. Open a PDF document you want to prepare for redacting by clicking on the “File > 
Open…” menu item from the main Acrobat menu. Make sure this document is not 
located on write-protected media (such as CD-ROM) and has security settings that permit 
document modification. Otherwise, copy this document to a different location or change 
document’s security settings. Refer to Acrobat User’s Guide for details (actual steps may 
depend on Acrobat release version). 
 
2. Select “Plug-ins > Redacting > Mark Up Text From Dictionary” from the main 
menu to open a “Select Redacting Dictionary” dialog. 
 
3. Select a redacting dictionary to use for search and markup by selecting one from the 
“Select dictionary to use” list. 
 
4. Select text matching options to use while searching for text from the redacting 
dictionary. Check “Match case” option to perform case-sensitive matching. When 
selected, the search operation looks only for occurrences that match the uppercase and 
lowercase characters you enter in the redacting dictionary. Check “Match whole words 
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only” to search only for whole words, rather than matching the text occuring within 
words. Results of the search operation are also affected by search settings specified in the 
“Markup” section of AutoRedact™ preferences. Make sure that “Perform matching 
across multiple text lines” option is selected if you want the matcher to ignore line 
breaks. 
 

 
 
6. Specify processing page range for the current operation.  

Select “All pages in the document” option to automatically process all pages in 
the currently open document. Choose “Current page” option to process currently 
visible page only, or specify a page range in the “Pages from – to” entry boxes. 
Select page subset from the following list: “All pages”, “Odd only” and “Even 
only”. The “Current Page” option is not available for selection when this dialog 
is accessed via batch processing framework dialog. This is due because there 
might be no currently active document open while creating or editing a batch 
processing sequence.  
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7. Click on the “Markup Preferences…” button to set visual appearance of the 
markup annotations that this operation is going to create. AutoRedact™ 
Preferences dialog will appear (only “Markup” section is accessible via this 
button) on the screen. Review and select desired processing settings.  

 
8. Click “OK” button to start searching for redacting text. AutoRedact™ plug-in 

displays a progress bar in the Acrobat’s status bar at the bottom of the screen. 
Processing speed largely depends on the number of pages being processed and the 
number of text occurrences marked. Creating annotations is a relatively slow 
process in the Adobe Acrobat®. AutoRedact™ plug-in optimizes annotation 
generation by trying to merge multiple annotations into a single one. Processing 
speed depends very little on the number of entries in the redacting dictionary. 

 
9. Confirmation dialog appears on the screen at the end of the processing displaying 

processing time, number of pages processed, total number of words marked in the 
document and a total number of annotations created.  

 

 
 

Sample image below illustrates the appearance of different annotation types that can be 
created by AutoRedact™ software:  
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Exemption codes are automatically added to annotations as a popup notes or comments. 
Assigned exemption code can be changed later by using any of the standard methods for 
editing annotations available in the Adobe Acrobat®. Select a “Hand” tool and double-
click on an annotation to open a corresponding comment note. First line of this note is 
used by AutoRedact™ as an exemption code. All additional lines can contain custom text 
and will be ignored during the actual redacting process. Use extra lines to add comments, 
notes or any other information you may find useful while preparing documents for 
redacting. The following snapshot shows an open note associated with a redacting 
annotation: 
 

 
 
Use this popup note dialog to change the exemption code associated with the redacting 
annotation. Click in the text area of the note and type new or edit existing text. Each 
popup note displays the name of the person (author) who created the annotation 
(Windows logon name is used to identify the author) along with the date and time. 
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Manual Markup Using Redacting Tool 
 
Areas on the page can be designated for redacting by drawing redacting areas with a 
redacting tool or by using Acrobat’s standard commenting and markup tools (such as 
highlight, cross-out, underline and rectangle). AutoRedact™ provides a redacting tool 
that is specifically designed for this operation. The redacting tool provides support for 
exemption codes that can be easily selected and automatically added to the redacting 
annotations. Exemption code is a special text that is placed on the page at the location of 
the redacted information to indicate the reason why this particular piece of information 
has been withheld.  
 
Manually adding annotation is convenient if you have to process just a few pages or if 
automated methods can’t be applied to your document. Use automated methods such as 
dictionaries, text patterns and templates if you know a specific form of the information 
that needs to be removed. 

Creating Redacting Annotations 
 
Select “Plug-ins > Redacting > Draw Redacting Areas…” from the menu to activate 
the redacting tool. The alternative method is to click on “Draw Redacting Areas” 
button on AutoRedact™ toolbar: 
 

 
 
“Redacting Tool” window will popup to indicate that you are now working with a 

redacting tool. Application cursor will be changed to indicate a redacting mode:   . 
The snapshot below illustrates the appearance of the “Redacting Tool” floating window: 
 

 
 
This window provides direct access to exemption code groups available in 
AutoRedact™. You can design your own custom exemption codes or use the 3 standard 
exemption code groups supplied with AutoRedact™. These standard code groups 
include: FOIA (Freedom of Information Act), Privacy Act, and Discovery Case 
exemption codes. You can switch between different groups by selecting a desired one 
from a “Select Group” pull down menu.  
 
Pick an exemption code that you want to assign to all new redacting annotations from 
“Select Code” pull down menu. “History” menu provides an ability to use history of 
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previously used codes to quickly switch between exemption codes in various exemption 
code groups. AutoRedact™ software always uses an exemption code currently selected in 
“Select Code” menu to assign to all new redacting annotations. 
 
Draw a rectangular area on the page around the text or image you’d like to redact. This 
will immediately create an annotation on the page according to current settings. See 
“Markup preferences” section for details on how to change the appearance of the 
redacting annotations. The snapshot below shows a manual redacting annotation created 
around a text paragraph: 
 

 
All text and images inside the redacting annotation are now selected for redacting. 
Current exemption code will be automatically assigned as a note to each new redacting 
annotation created with the “Redacting Tool”. 

Editing Exemption Codes 
 
Exemption codes are stored as text notes attached to the redacting annotations. 
AutoRedact™ only uses the first line of the note as an exemption code. This allows using 
extra lines as custom notes or comments. Only first line of the note will be added to the 
final redacted document as an exemption code. You can edit exemption codes assigned to 
the redacting annotations using two different methods: 
 

1. Use “Comments” navigation tab to navigate and edit notes. Select “View > 
Navigation Tabs > Comments” from the menu. Use excellent “Comments 
Tab” controls to navigate, edit or delete exemption codes attached to annotations. 

2.  Double-click on the redacting annotation with a “Hand” or “Select” tool to open 
a popup note window. Edit exemption code in the popup window. 

 
Redacting tool can also be used to assign more than one exemption code to a single 
redacting annotation. Move application cursor inside the existing annotation and it will 

change its shape to . Click inside the annotation rectangle to add currently selected 
exemption code to the annotation. This method can be used to quickly assign multiple 
exemption codes to an existing redacting annotation. 
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Editing Redacting Annotations 
 
The size and location of the existing redacting annotations can be easily changed using 
“Hand” or “Select” tools. Annotations can be resized and moved to a new location. 

Creating and Editing Custom Exemption Code Groups 
 
You can create any number of custom exemption code groups and use them while 
working with the redacting tool. Exemption code group is a logical collection of 
exemption codes that are typically used together. Follow the following step to create a 
new exemption code group: 
 

1. Select “Plug-ins > Redacting > Preferences” from the main menu. 
2. Select “Exemption Codes” tab in the “Redacting Preferences” dialog. 

“Exemption Codes” tab lists all currently existing code groups available on the 
computer.  
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3. Click on “Create New” button to create a new exemption code group or click 
“Edit” to edit an existing group. You need to select an existing code group first 
before you can edit it. “Edit Exemption Codes” dialog will popup on the screen. 

4. Enter “Group Title” and “Description” text. This text is used to label the 
exemption code group in the “Redacting Tool” window. 

5. Click “Add Code…” button to add a new exemption code to the group. 
 

 
 

6. Enter exemption code text and description in “Exemption Code Details” dialog.  
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7. If you wish to create a hierarchical menu-like structure of exemption codes then 
select any existing exemption code in the tree view and click “Add Sub-
Category…” button. New exemption code will be created as a child of the 
selected code.  

 
8. Each exemption code has a check-button associated with it that controls visibility 

of the code in the “Redacting Tool” window. Turn this check-button off to 
temporary remove the code from the “Redacting Tool” menu.  

 
9. You can move exemption code up and down in the tree by clicking “Move Entry 

Up” and “Move Entry Down” buttons. 
 

10. To delete an exemption code: select it in the tree view and click “Delete…” 
button. Confirmation dialog will popup to verify your selection. 

 
11. Click “OK” button to save exemption code group once you have completed the 

editing. 
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Marking Up Text Patterns 

Using Built-in Patterns 
 
AutoRedact™ can search a document for occurrence of a specific text or a text pattern 
and automatically mark them for redacting. The software offers a selection of common 
text patterns such as: 
 

• Social Security Numbers 
• Employer Identification Numbers 
• Phone and fax numbers 
• Email addresses 
• Dates 
• Postal addresses 
• Company names (limited subset of patterns recognized) 
• Text within square brackets  

 
Custom text or a text pattern can also be used to find and mark all occurrences of a text in 
the document. AutoRedact™ supports powerful regular expression syntax that allows 
description of complex text patterns. See “Regular Expressions for Pattern 
Matching” section for more details about regular expression syntax and capabilities. 
You do not need any knowledge of the regular expressions syntax if you want to use any 
of the built-in patterns or just want to search for a specific string. 
 
All occurrences of the specified text patterns within a working page range will be 
automatically marked with redacting annotations. Use “Markup” tab of “Redacting 
Preferences” dialog to specify a preferred redacting annotation style and visual 
appearance. 
 
To mark up text patterns in the document: 
 

1. Select “Plug-ins > Redacting > Mark Up Text Pattern” from the main menu. 
 
2. Select desired text patterns to search for in the “Mark Up Text Patterns” dialog. 

 
3. Enter exemption code (type into “Exemption code to use:” text box) to assign 

to all new redacting annotations that are going to be created as the result of this 
operation. 

 
4. Select a processing page range and subset.  

 
5. Click on “Edit Preferences…” button to optionally change style and appearance 

of the redacting annotations.  
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6. Click “OK” button to start processing. 
 

10. Confirmation dialog appears on the screen at the end of the processing displaying 
a processing time, number of pages processed, total number of words marked in 
the document and a total number of annotations created.  
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Defining Custom Patterns with Regular Expressions 
 

1. Check “Markup using a custom text pattern” option to enter a custom text or 
a text pattern.   

 
2. Enter actual text or pattern to search for into the “Find what” text box. Refer to 

“Regular Expressions for Pattern Matching” section for more details on how 
to write and use regular expressions. You don’t have to use regular expressions if 
you’d like to find an occurrence of a specific string. Just type the text you are 
looking for in the “Find what” text box. However, there are a few special 
characters that are interpreted differently by the regular expression syntax: . 
(period), |,^,\ (backslash) ,^ , $. Add a backslash in front of any special character 
to ignore its special meaning.  

 
3. Check “Match case” option for case-sensitive search. 

 
4. Check “Match whole words only” option to search only for whole words, rather 

than matching the text as it occurs within words. 
 
5. Select a processing page range and subset.  

 
6. Click on “Edit Preferences…” button to optionally change style and appearance 

of the redacting annotations.  
 

7. Click “OK” button to start processing. 
 

11. Confirmation dialog box appears on the screen at the end of processing. It 
displays processing time, number of pages processed, total number of words 
marked in the document and a total number of annotations created.  

 
Working with custom text patterns is typically an iterative process. Try a regular 
expression and review the results. The results may be too broad or too narrow. If you 
need to try a different text pattern then it’s a good idea to delete all unwanted redacting 
annotations first. Select “Plug-ins > Redacting > Remove All Annotations” from the 
menu or use “Redacting” toolbar.  
Regular expressions are very powerful for specifying text patterns but require certain 
skills that are relatively easy to master. If you are unfamiliar with text matching – do not 
feel discouraged. After a bit of trial and error you will be able to command regular 
expressions to solve most of your tasks. You can always contact EverMap tech support at 
tech@evermap.com and ask for help. We will be glad to help you to create the right 
regular expression for your project.  
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Regular Expressions for Pattern Matching  

What is a regular expression? 
  
A regular expression (often abbreviated as regexp, regex, or regxp, with plural forms 
regexps, or regexes) is a string that describes or matches a set of strings, according to 
certain syntax rules. Regular expressions are used by many text editors and utilities to 
search and manipulate bodies of text based on certain patterns. AutoRedact™ software 
uses regular expressions in the “Mark Up Text Pattern” operation to describe the text 
that needs to be marked for redacting.  
 
A regular expression is a specification of the template that the text must fit. It is a text 
string which is used to match against other strings. Some characters have special meaning 
when used in regular expressions whereas other characters stand for themselves. A 
regular expression is a pattern that is matched against a subject text from left to right. 
Most characters stand for themselves in a pattern, and match the corresponding characters 
in the subject. Regular expressions are also described in the Perl documentation and in a 
number of other books and online resources, some of which have copious examples. 
There are many web sites that serve as online repository of useful regular expressions. 
The description here is intended as introductory documentation only.   

Introduction to Regular Expressions 
  
A regular expression, or regex for short, is a pattern describing a certain amount of text. It 
has a special syntax which allows you to form a kind of a template against which the 
other strings can be matched. In this document, regular expressions are highlighted in 
bold red as regex. Term "string" is used to indicate the text that regular expression is 
applied to. Text strings will be highlighted as follows: “Text string”. 
  
The simplest form of regular expression is literal text. For example, regex Chapter 
matches text strings containing Chapter sub-string. The power of regular expressions 
comes from the ability to include alternatives and repetitions in the pattern. These are 
encoded using meta-characters, which are interpreted in a special way.  

Character types 
  
Backslash can be used to specify generic character types: 
 
\d any decimal digit 
\D any character that is not a decimal digit 
\s any white space character 
\S any character that is not a white space character 
\w any "word" character (A "word" character is any letter or digit or the underscore 
character) 
\W any "non-word" character 
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For example: \d{8} matches exactly 8 digits.  

Matching alternatives 
  
Vertical bar characters are used to separate alternative patterns. For example, the pattern 
Configuration|Settings matches either "Configuration" or "Settings". Any number of 
alternatives may appear, and an empty alternative is permitted (matching the empty 
string). The matching process tries each alternative in turn, from left to right, and the first 
one that succeeds is used. 

Sub-Patterns 
  
Sub-patterns are delimited by parentheses (round brackets), which can be nested. For 
example, the pattern ((red|white) (BMW|Volvo)) matches either "red" and "white" 
followed by either "BMW" or "Volvo" (i.e. "red BMW" or "white Volvo"). Another 
example: (sens|respons)e and \1ibility matches "sense and sensibility" and "response 
and responsibility", but not "sense and responsibility". If instead the pattern 
(sens|respons)e and (\1)ibility is used, it will match "sense and responsibility" as well as 
the other two strings. The meta-character \1 here serves as a back reference to the first 
matching sub-pattern. Such references must, however, follow the sub-pattern to which 
they refer. 

Matching whole words 
  
Simple text patterns such as Alert are also going to match words Alerts, Alerted and etc. 
If you want your pattern to match only whole words, surround it with \b meta-characters. 
For example, use \bAlert\b to match word Alert but not match words that might contain 
it as a sub-string. 

Matching sub-string 
  
If the text that you want to match appears only inside other words, use \B meta-character. 
For example, the pattern \Bword\B will match word "swordfish", but will ignore words 
"word", "words" and "password". 

Repetitions 
  
The general repetition quantifier specifies a minimum and maximum number of 
permitted matches, by giving the two numbers in curly brackets (braces), separated by a 
comma. The numbers must be less than 65536, and the first must be less than or equal to 
the second. For example: z{2,4} matches "zz", "zzz", or "zzzz". A closing brace on its own 
is not a special character. If the second number is omitted, but the comma is present, 
there is no upper limit; if the second number and the comma are both omitted, the 
quantifier specifies an exact number of required matches.  
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Character Classes or Character Sets 
 
A "character class" matches only one out of several characters. To match an “a” or an 
“e”, use [ae]. You could use this in gr[ae]y to match either gray or grey. A character 
class matches only a single character. gr[ae]y will not match graay or graey for instance. 
The order of characters inside the character class does not matter. You can use a hyphen 
inside a character class to specify a range of characters. [0-9] matches a single digit 
between 0 and 9. You can use more than one range. [0-9a-fA-F] matches a single 
hexadecimal digit, ignoring case. You can combine ranges and single characters. For 
instance [0-9a-fxA-FX] matches a hexadecimal digit or the letter X. 
Including a caret after the opening square bracket will negate the character class. The 
result is that the character class will match any character that is not in the character class. 
q[^x] matches qu in question. It will match q followed by any character except x. It does 
not match Iraq since there is no character after the q for the negated character class to 
match. 

Using Anchors to Match Text Lines  
 
Anchors do not match any characters. They match only a particular text position in the 
string. Meta-character ^ matches the start of the string, and $ matches the end of the 
string. Symbol \b matches the word boundary. For instance, ^b matches only the first b 
in bob. Word boundary is a position between a character that can be matched by \w and a 
character that cannot be matched by \w. Meta-character \b also matches at the start and/or 
end of the string if the first and/or last characters in the string are word characters. \B 
matches at every position which \b does not match. 
 
Examples:  
 
Chapter \d$ - matches Chapter 1 , but does not match Chapter 1 Appendix 
^Chapter \d - matches Chapter 1 , but does not match In the Chapter 1 
Chapter\b - matches Chapter or Chapter 1, but does not match Chapters
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Marking Up Content with Templates 

Templates Overview 
 
Certain types of documents, such as official forms or statements, contain specific text or 
images that are positioned at fixed locations on the page. For example, a billing statement 
may always display a customer name or an account number at pre-determined location 
within a page or a document. AutoRedact™ uses templates to markup information that is 
located at known locations within a document. Template is a collection of redaction 
annotations (including visual appearance and associated exemption codes) that has been 
saved to an external file. It can be used to markup content in other documents. Template 
file may contain redacting annotations for one or more pages and can be repeatedly 
applied to any compatible document. For example, you can create and save a one-page 
template that marks up an account number on the first page of a billing statement. This 
template can be applied to a document that contains thousands of individual billing 
statements. You can specify which pages to apply this template to when processing a 
document. For example, you can choose to apply the template every 3 pages (the length 
of the single billing statement). When applying the template, all redacting annotations 
from it will be copied to the corresponding pages in the target document while preserving 
their positions and visual appearance.  

Creating Templates 
 
Templates do not require any special tools to create. Open a sample of the document that 
you plan to use the template on. Use any method available in AutoRedact™ and Adobe 
Acrobat® to create the desired set of redacting annotations.  
Redacting annotations may span one or more pages and include all valid redacting 
annotation types. Redacting annotations are saved to a template starting from the first 
page of the document. Make sure that you design redacting annotations assuming that the 
first page of the current document corresponds to the first page of your template. Once 
you have created all redacting annotations you can save them to a template file.  
 
To create a redacting template: 
 

1. Use various “markup” tools provided by AutoRedact™ plug-in to create redacting 
annotations on one or more pages of the sample document. Verify that all 
necessary exemption codes are assigned and redacting annotations are positioned 
as correctly. 

 
2.  Select “Plug-ins > Redacting > Save Current Markup As Template…” 

from the main menu. “Redacting Template Info” dialog should appear on the 
screen. 

 
3. Enter redacting template description text into “Template Description” text. This 

text is optional and is used for informational purpose only. It will help you 
correctly identify the purpose of this template later. 
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4. Specify how many pages from the current document will be stored in the 

template. AutoRedact™ counts pages from the beginning of the document. If you 
select “1” then only the first page of the document will be stored in the template. 
If “2” is selected then first two pages will be stored and etc. 

 

 
 

5. Enter the number of pages to repeat this template when it applied to the 
document. You can change this value later when applying the template. However, 
it is strongly recommended to enter a correct number of pages that this template 
has been designed for. You can easily forget all details about the template few 
weeks later and pre-selecting all values is a good way to preserve your work. 

 
6. The name of the user (author) and the location of the document used to design this 

template will be automatically stored in the template.  
 

7. Click “OK” to save the template to the external file. “Save As” dialog should 
appear on the screen prompting for the output filename. Navigate to the desired 
location on your computer and enter a filename. AutoRedact™ stores all 
templates in the proprietary file format with AMT extension. 

 
Once you saved a template to a file it can be used to add redacting markup to other 
compatible documents. It order to preserve a correct placement of annotations, 
documents should have page sizes identical to the sample document that has been used to 
design the template. The location of the redacting annotation is stored relative to the 
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lower-left corner of the page. If a template is applied to a document with a different page 
size then redacting annotations will be shifted relatively to lower-left corner of the page. 

Applying Templates 
 
To apply a redacting template: 
 

1. Select “Plug-ins > Redacting > Mark Up Text With Template…” from the 
main menu. “Open” dialog box should appear on the screen. 

 
2. Select AutoRedact™ markup template file (*.AMT) and click “OK” button. 

 
3. “Redacting Template Info” dialog should appear on the screen displaying 

details about the selected template: 
 

 
 
Most fields in this dialog box are read-only. You can only change the number of 
pages to repeat the template for the current document. No changes made in this dialog 
box will be saved to the template file.  

 
4. Click “OK” button to apply redacting annotation to the current document. All 

annotations from the template will be added to the document. Software will repeat 
the template number of pages specified starting from the first page of the 
document. For example, suppose you have a template that contains 2 pages and 
needs to be repeated every 3 pages. When this template is applied, first “page” of 
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the template will be applied to the first page of the document and second “page” 
of the template will be applied to the second page of the document. When the end 
of the template is reached, software will repeat this template after a 3 page 
interval. The whole process will be repeated starting from the pages 3, 6, 9 and 
etc. Software will continue to apply a template until the end of the document is 
reached. 

 
5. At the end of processing, a confirmation dialog box will appear, displaying 

processing time, number of pages processed, and the total number of annotations 
created.  
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Marking Up All Text 
 
Some documents may require redacting all text in certain pages or in the whole 
document. For this purpose, AutoRedact™ provides a “Mark Up All Text” operation. 
 
To mark up all text elements within a page range: 
 

1. Select “Plug-ins > Redacting > Mark Up All Text” from the main menu or 
use “Redacting” toolbar. “Markup All Text” dialog should appear on the 
screen: 

 

 
 

2. Select a processing page range: “All pages in the document”, “Current Page” 
or “Pages from – to”.  

 
3. Select page subset from “All pages”, “Odd only” or “Even only”. 

 
4. Specify exemption code to assign to all new annotations to be created during this 

operation. NOTE: This operation uses “Rectangle” style to create redacting 
annotations. 

 
5. Optionally click on “Edit Preferences…” button to change “Markup” settings 

that affect visual appearance of redacting annotations.  
 

6. Click “OK” button to start processing. All text elements within specified page 
range will be marked for redacting. 
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Marking Up All Images 
 
Some documents may require redacting of all images within certain pages or the whole 
document. For this purpose, AutoRedact™ provides a “Mark Up All Images” operation 
that automatically marks up all image objects for redacting. 
 
To mark up all text elements within a page range: 
 

1. Select “Plug-ins > Redacting > Mark Up All Images” from the main menu. 
“Markup All Text” dialog should appear on the screen: 

 

 
 

2. Select a page range to process: “All pages in the document”, “Current Page” 
or “Pages from – to”.  

 
3. Select page subset from “All pages”, “Odd only” or “Even only”. 

 
4. Specify exemption code to assign to all new annotations to be created during this 

operation. NOTE: This operation uses “Rectangle” style to create redacting 
annotations. 

 
5. Optionally click on “Edit Preferences…” button to change “Markup” settings 

that affect visual appearance of redacting annotations.  
 
Click “OK” button to start processing. All image objects within the specified page range 
will be marked for redacting. 
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Reviewing Redacting Markup 
Overview 
 
Once you have marked the document content for redacting, you need to inspect and 
verify the resulting annotations. This step is not mandatory and does not involve 
execution of any special operations, but it’s recommended as part of a solid redacting 
workflow. By reviewing redacting annotations you are making sure that only desired 
information will be removed from the document. It also helps to ensure that no 
confidential information has been omitted from redacting.  
Redacting review might include visual inspection of the pages or individual redacting 
annotations, editing redacting areas and exemption codes, exporting document to a text 
file (to maintain records), printing a document with redacting annotations.  

Navigating and Editing Redacting Annotations 
 
Efficient and convenient navigating between many redacting annotations is very 
important during the review procedures. Adobe Acrobat® offers excellent tools for 
working with comments that can be also used for redacting annotations since 
AutoRedact™ uses standard annotations types for content markup. 
 
Using comment navigation tab you can quickly jump from one annotation to another, 
view all information related to annotations such as author, date and subject, search for 
annotations with specific exemption code or comments, print annotation with exemption 
codes, edit exemption codes attached to annotations. AutoRedact™ uses annotation notes 
to store exemption code making it very easy to modify.  
 
To open or close “Comments” navigation tab: 
 

1. Select “Plug-ins > Redacting > Show/Hide Navigation” or click on 
“Show/Hide Navigation” button in the “Redacting” toolbar. 

2. Alternatively, you can select “View > Navigation Tabs > Comments”. 
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Use navigation buttons located on the top of the “Comment” tab to navigate between 
redacting annotation in the document: 
 

 
Click “Expand All” button to expand all annotations. Expanded annotations will display 
their author, subject, date, and note fields. 
Click “Collapse All” button to collapse all annotations. Comments list will be collapsed 
to show only page nodes. 
 

 
Click “Next” or “Previous” buttons to move to the next or previous annotation. 
Redacting annotation will be highlighted in the page view and document will be 
automatically scrolled to make that annotation visible. 
 

 
Click “Delete” button to delete currently selected annotation. Exercise caution since 
Adobe Acrobat® will immediately delete the annotation without prompting you to 
confirm the deletion. Select “Edit > Undo” from the main menu to restore accidentally 
deleted annotation. 
 

 
Click “Show” button to open a pull-down menu that allows you to customize how and 
what annotations are displayed in the “Comments” tab. For example, you may display 
only annotations created by a specific author (reviewer) or annotations of the specific 
type. 
 
Click “Sort By” button to open a pull-down menu that allows you sort annotations in the 
“Comments” tab. Annotations can be sorted by “Type”, “Page”, “Author”, “Date”, 
“Color” and “Checkmark” status. Checkmarks have no specific meaning and can be 
used by user to indicate a custom information or status. 
 

 
Click “Search” button to open a search panel that lets you quickly search all comments 
(exemption codes are part of the comments) for occurrences of a specific string. Search 
results are displayed in the separate window. Click on a search result to highlight 
corresponding annotation. “Search” functionality is very useful when you want to look 
only at redacting annotations with a specific exemption code. 
 

 
Click the “Print Comments” button to print or created PDF with summary of 
comments. Summary document contains pages with comments from the original 
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document as well as automatically generated “summary” pages (“summary” pages are 
inserted right after corresponding document page). “Summary” page contains detailed 
information about each annotation on the given page. There might be more than one 
“summary” page for each document page containing annotations. If certain page has not 
annotations then a blank “summary” page will be attached with message “This page 
contains no comments”. 

Editing Exemption Codes 
 
There is a number of different methods that can be used to edit the exemption code. 
AutoRedact™ uses comments or notes attached to redacting annotation to store the 
exemption code. You can edit exemption codes in the popup window of the note or use 
“Comments” tab. Using “Comments” tab is convenient when you have to modify many 
redacting annotations or search for a specific exemption code.  
 
Only the first line of the note is used as an exemption code during the redacting process. 
Use extra lines to add comments, notes or any other information you may find useful 
while preparing documents for redacting. All but the first text line will be ignored during 
the redacting process. This simple method allows you to keep the exemption code and 
custom comments related to a single annotation in one place. 
  
To edit exemption code or comments in the popup note window: 
 

1. Double-click the annotation using “Hand” or “Select” tool. Popup window 
should appear on the screen. Click inside the popup and type or edit the text. 

 

 
 

2. Click on the little “x” button in the upper-right corner of the window to close the 
popup window once you’ve finished working with it. Popup window will 
disappear from the screen. 

 
To edit the exemption code in the “Comments” navigation tab: 
 

1. Select “Plug-ins > Redacting > Show/Hide Navigation” or click on 
“Show/Hide Navigation” button in the “Redacting” toolbar. 
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2. Select annotation from the list and click on the comments area. It will be 
converted into a text box where you can edit the exemption code. 

Moving and Resizing Redacting Annotations 
 
Redacting annotations of the “Rectangle” style can be easily moved or resized using 
standard “Hand” or “Select” tools. Click on border of the annotation and then drag it to 
the desired location on the page. Move the cursor over the corners of the annotation 
(cursor will change it shape to indicated “resize” mode) to resize the annotation. 
 
Redacting annotations of “Highlight”, “Underline” and “Cross-out” styles can not be 
moved in Adobe Acrobat®. They are typically created in conjunction with text elements 
and are not movable or resizable using standard Acrobat tools. 
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Converting Page Content to Image 
 
AutoRedact™ plug-in can redact information that is contained in the text and image 
elements of PDF documents. Postscript graphics can’t be safely redacted in their original 
form so they need to be converted to an image. Such drawing or graphics are represented 
in the PDF file as a series of drawing commands (instructions) and can’t partially 
modified without affecting the rest of the graphics. AutoRedact™ plug-in offers a 
solution for this problem by providing “Convert Page Content To Image” conversion 
operation. This operation will convert ALL page contents into a black-and-white image 
and remove all original page elements. Black-and-white images can’t adequately 
reproduce color or gray-scale information, however they offer the smallest data size 
available compared to other data types. Images take up considerably more disk space then 
graphics or text. The resulting document size will increase in size after converting pages 
to images. The amount of this increase depends on how much information is presented on 
the page. Mostly white or mostly black images can be efficiently compressed and will not 
significantly increase the size of the output document. It’s suggested to convert only 
those pages that are actually contain graphics that need to be redacted rather than 
converting the whole document. 
 

1. Select “Plug-ins > Redacting > Advanced > Convert Page Content to 
Image…” from the menu to convert pages that contain drawings (graphics) that 
need to be converted to images.  

 

 
 

2. Select a range of pages and page subset that needs to be processed. Whole content 
of each page will be replaced with a single image and all other elements will be 
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deleted from the document. The output resolution greatly affects quality and 
appearance of the resulting image. Image resolution can be adjusted from low-
quality 150 dpi to high-quality 600 dpi. Note that higher quality and resolution of 
the image comes with significantly increased file size needed to represent more 
information. This conversion operation creates a black & white images and will 
change appearance of the color graphics. 

 
To adjust image resolution for the conversion process click on “Edit Preferences…” 
button. Adjust “Graphics to image conversion resolution” option to a desired value 
and close the document. You have to do it once only, since AutoRedact™ will remember 
this preference for the next time.  
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Exporting Text Content to ASCII File 
 
Document content can be exported into ASCII text file to keep the record of document 
content before and after redacting. AutoRedact™ uses slightly different export format 
than standard text export available in Adobe Acrobat®. Text files created by 
AutoRedact™ also include page breaks, page numbers and word counts to help navigate 
and review the exported text.  
 
To export a document to an ASCII text file: 
 

3. Select “Plug-ins > Redacting > Advanced > Export To Text File…” from 
the main menu. “Save As” dialog box should appear on the screen. 

 
4. Select output filename and location. Click “OK” to save the document. 

 
The sample below shows a portion of ASCII text file that has been exported using this 
operation: 
 
------------------------ PAGE 1 ------------------------ 
Report # I333-015R-2005  
Date 12/13/2005  
Redacting with Confidence: How to Safely Publish  
Sanitized Reports Converted From Word to PDF  
Architectures and Applications Division  
of the  
Systems and Network Attack Center (SNAC)  
Information Assurance Directorate  
National Security Agency  
ATTN: I333  
9800 Savage Rd. STE 6704  
Ft. Meade, MD 20755-6704  
(410) 854-6191 commercial  
(410) 854-6510 facsimile  
W2Kguides@nsa.gov  
CLASSIFICATION//X1 
---------- NUMBER OF WORDS ON PAGE 1 : 69 ------------ 
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Printing Redacting Annotations 
 
Redacting annotations can be printed as a part of the document by using a regular “File > 
Print…” menu or printed as a part of the comments summary document. 
 
To print redacting annotations on top of the document: 
 

1. Select “File > Print…” from the main menu. “Print” dialog box should pop up 
on the screen. 

 
2. Select desired output device and printing options. 

 
3. Select “Comments and Forms” > “Document and Markup” to print 

annotation on top of the document. 
 

4. Click “OK” button to start printing. This will print document pages with redacting 
annotations on top. No exemption codes or comments will be printed. See the 
next section “Printing Redacting Summary Document” for details on how to 
print redacting annotations and all the corresponding information together. 

 
The snapshot below shows a small sample of the printed document with redaction 
annotations on top: 
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Printing Redacting Summary Document 
 
To print redacting annotations along with exemption codes as a “summary” document: 
 

1. Open “Comments” navigation tab by selecting “Plug-ins > Redacting > 
Show/Hide Navigation” or click on the “Show/Hide Navigation” button in 
the “Redacting” toolbar. 

 
2. Click on the “Print Comments” menu and select “Create PDF of Comments 

Summary”. Comments summary document will be generated and displayed in 
Adobe Acrobat®. You can print this summary as a regular PDF document by 
selecting “File > Print…” from the main menu.  

 
Summary document contains pages with comments from the original document as 
well as automatically generated “summary” pages (“summary” pages are inserted 
right after corresponding document page). Summary page contains detailed 
information about each annotation on the given page. There might be more than one 
“summary” page for each document page containing annotations. If a certain page 
contains no annotations then a blank “summary” page will be attached with message 
“This page contains no comments”. The snapshot below shows a sample of the 
summary document with an original page on the left (note a small number by each 
redacting annotation) and redacting annotation summary (including an exemption 
code) on the right. 
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Redacting Marked Content 
 
Once all of the desired text and images have been marked for redacting you can run the 
actual redacting procedure to remove selected content from the document. Redacting can 
be performed directly on the original document or on an automatically created copy. Text 
can be redacted using either blank space symbol or any other selected character. Various 
options are available that affect final appearance of the redacted document. Color bars 
and exemption codes can be added to the document to indicate where and why the 
information has been removed.  

Specifying Redacting Preferences 
 
Redacting preferences can be accessed from the menu or from the redacting toolbar. 
Select “Plug-in > Redacting > Preferences…” from the menu to open the 
“Redacting Preferences” dialog box.  “Redacting” tab contains options and settings 
that control visual appearance of the final redacted document and the processing logic of 
the redacting operation. Consult “Redacting Preferences” chapter in this manual for 
detailed description of all redacting options and settings.  

Redacting the Document 
 

1. Select “Plug-ins > Redacting > Redact Marked Content…” from the menu 

or click on the “Redact marked Content” button (   ) on the redacting 
toolbar. “Redact Document” should popup on the screen: 
 

 

 
AutoRedact™ User’s Guide  61 



www.evermap.com  EverMap Company, LLC. 
 

2. Select a range of pages and page subset for processing. Only selected pages will 
be redacted. 

  
3. You can access redacting preference by clicking the “Edit Preferences” button. 

“Redacting Preferences” dialog box will appear on the screen. Specify all 
redacting preferences and click “OK” to close the preferences dialog box and save 
settings. AutoRedact™ will remember your preferences so that you don’t have to 
enter them every time you run the software. 

 

 
 
4. Check “Create a new document for redacting output” option if you do not 

want to modify your original document. A copy of the document will be created 
and redacting will be performed on it without touching the original. Note that this 
option is not applicable when redacting in the batch framework. Batch processing 
performs all operations directly on the input document and provides a way to save 
output document under a different name or in the different location. Consult 
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“Selecting Redacting Preferences” chapter in this manual for detailed 
description of settings and parameters. 

 
5. Click on the “Redacting” tab of the “Redacting Preferences” dialog to specify 

the visual appearance of the redacted document and processing logic.  
 

 
 

Consult “Selecting Redacting Preferences” chapter in this manual for detailed 
description of all settings and parameters. 

  
6. Click “OK” button to close “Redacting Preferences” dialog. Click “OK” button 

on the “Redact Document” dialog to start processing. Confirmation dialog box 
appears on the screen at the end of the processing stage displaying processing 
time, number of pages processed, and the total number of annotations created.  
Review redacting output and save the document under desired filename. 
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Removing Annotations 
 
There are many types of annotations that are used in Adobe Acrobat for a wide variety of 
tasks. Comments, notes, drawing markup, highlights, multimedia clips, text notes, 
typewriter text, and interactive form fields are all examples of Acrobat annotations. Many 
of these annotation types can potentially contain confidential information (such as notes) 
or only be used while working on the document. Once a document has been redacted, it’s 
a good idea to remove all annotations (including redacting annotations) from it for an 
additional degree of protection from accidental disclosure of confidential information.  
 
To remove annotations from the document: 
 

1. Select “Plug-ins > Redacting > Remove All Annotations…” from the main 
menu. “Remove Annotations” dialog box should appear on screen: 

 

 
 

2. Select a range of pages and page subset that needs to be processed. 
 
3. Optionally select whether you want to remove certain types of annotations that 

sometimes may be necessary to retain in the document (such as text notes, 
multimedia annotations, and form fields). 
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4. Click “OK” button to start removing annotations from the document. 

 
5. Inspect the document to make sure that annotations have been properly removed. 
 

Removing File Attachments 
 
PDF documents can contain embedded file attachments. This capability poses additional 
risk of accidental disclosure of confidential information. File attachments may not be 
easily visible on screen (especially in older version of Adobe Acrobat) and it’s quite easy 
for them to slip unnoticed during the redacting review. You would have to specifically 
check for presence of file attachments in order to verify if the document has any. 
AutoRedact™ plug-in provides a one-step operation that automatically removes all file 
attachments from the document. This operation is also available in Acrobat batch 
framework to allow automatic removal of file attachments in the batch mode. 
 
To remove all file attachments from the document: 
 

1. Select “Plug-ins > Redacting > Remove All Attachments…” from the main 
menu. 

 
2. Click “OK” in the verification dialog to start removing embedded file 

attachments. 
 

3. Software will display an information message if a current document does not have 
any file attachments. 
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Inspecting the Results 
 
After all redacting operations have been completed it is generally a good idea to inspect 
the resulting document for possible omissions and perform other steps that may be 
necessary before releasing the document to the public: 
 

1. Perform a text search or apply some of the redacting markup operations such as 
“Markup by Text Pattern” or “Markup Words From Dictionary” to see if 
there are any unwanted words or phrases accidentally left in the document.  

 
2. Make any final changes to the document. 
 
3. Maker sure that no unwanted annotations have been left in the document. Apply 

“Remove All Annotations” operation if required. 
 

4. Make sure that the final document has no file attachments that should not be 
there. Click on the “Attachments” tab in the document view or select “View > 
Navigation Tabs > Attachments” from the menu. Review the list of attached 
files and remove any unwanted files. 

 
5. Edit document properties – enter or modify “Author” , list of keywords and 

document descriptions. Select “File > Document Properties…” to access 
“Document Properties” dialog. 

 
6. Optionally secure document content or restrict document access, editing 

priviledges or printing priviledges. Select “Document > Security > Secure 
This Document…” from the menu to review and modify document security 
settings. 

 
7. Optionally digitally sign the document. Select “Document > Digital 

Signatures > Sign This Document” from the menu to secure the document. 
 

8. Save final version of the redacted document by selecting “File > Save As…” 
from the menu.  
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Saving and Loading Preferences 
 
Most options and settings that are used by AutoRedact™ for markup and redacting are 
accessible from the “Redacting Preferences” dialog box. This dialog box can be 
accessed by selecting “Plug-ins > Redacting > Preferences…” from the main 
Acrobat menu or by clicking on the “Preferences” icon in the “Redacting” toolbar. The 
redacting preferences that are listed on “General”, “Markup” and “Redacting” tabs 
can be saved to a settings file. You can share settings file with other team members to 
ensure that everyone in your team are working with the same configuration.  
 
To save current redacting preferences to a settings file: 
 

1. Select “Plug-ins > Redacting > Manage Preferences > Save 
Preferences…” from the main Acrobat menu. “Save As” dialog should appear 
on the screen prompting you to select output file name and location. 

 
2. Select output file name and location for the setting file and click “OK” button. 

You can select new or existing file. This will save current preferences to a 
selected settings file with *.RED extension. 

 
To load redacting preferences from a settings file: 
 

1. Select “Plug-ins > Redacting > Manage Preferences > Load 
Preferences…” from the main Acrobat menu. “Open” dialog box should appear 
on the screen prompting you to select an input settings file. 

 
2. Select previously saved settings file (AutoRedact™ settings files have *.RED 

extension) and click “OK” button. Redacting preferences will be loaded from the 
selected file and will overwrite any preferences you are currently using.  
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Redacting Logs 
Overview of the Redacting Logs 
 
AutoRedact™ plug-in keeps track of all redacting operations it performs on each 
document by maintaining a special log file. The plug-in automatically creates a separate 
log file for each processed document. The log file is created in HTML format making it 
easier to view, navigate and print using any web browser (such as Microsoft Explorer, or 
Firefox).  
 
Redacting log files are stored in the same folder as the corresponding PDF documents. 
Log files have the same name as PDF files, but a different extension – HTM. Each 
redacting operation automatically adds records to the log file describing the details of the 
performed processing. It’s possible to turn logging on and off by checking “Output log 
files for each processed document” option in “Redacting Preferences” dialog. Log 
files are enabled by default. 
 
To turn automatic logging on or off: 
 

1. Select “Plug-ins > Redacting > Preferences…” from the main menu. 
 
2. Make sure “General” tab is selected. 

 
3. Use “Output log files for each processed document” check button to toggle 

automatic logging. 
 
Log files can be viewed, printed and cleared. 
 
The example below shows a small portion of the sample log file: 
 
Operation performed: MARKUP TEXT PATTERNS 
Processing started: Tuesday, May 09, 2006 at 18:58:03 
Processing stopped: Tuesday, May 09, 2006 at 18:58:05 
Processing time: 00 hour(s) 00 minute(s) 02 second(s) 
Adobe Acrobat Version: 7.5 
AutoRedact Plug-in Version: 1.1, Build Date: Apr 27 2006 
Author: Admin 
Number of records: 28 
Number of pages processed: 66 
Number of deleted characters: 0 
Number of redacted images: 0 
Number of words marked up: 20 
Number of images marked up: 0 
Number of annotations deleted: 0 
To end of the report 
To top of the log file 
Total number pages in the document: 66 
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Document PDF version: 1.6 
Document creator: Adobe InDesign 2.0.2 
Document producer: Adobe PDF Library 5.0 
Processing page range: All 
Processing page subset: All 
------------------------START------------------------------ 
Pattern: Passport 
Page 6, Keyword: "passport" 
Page 6, Keyword: "passport" 
Page 8, Keyword: "passport" 
Page 16, Keyword: "passport" 
…… 

Viewing and Print Redacting Logs 
 
To view the redacting log file for the current document: 
 

1. Select “Plug-ins > Redacting > View Log File…” from the main menu or use 
“View Log File” button on “Redacting” toolbar. 

 
2. Software will automatically find and open corresponding log file in an external 

browser window. Use the browser to view, navigate and print redacting logs. 
 

3. Warning dialog will be displayed if no log file is currently available for the 
current document. 

 

Clearing Log Files 
 
To clear (remove) a log file for the current document: 
 

1. Select “Plug-ins > Redacting > Advanced > Clear Log File For Current 
Document…” from the main menu. Confirmation dialog box will appear on the 
screen. Click “OK” to proceed. 

 
2. Software will automatically find and delete corresponding log file. 
 
3. Warning dialog bx will be displayed if no log file is available for the current 

document. 
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Batch Processing 
Overview of the Batch Processing 
 
When you apply one or more sets of commands to your documents, you can save time 
and keystrokes by using an automated batch sequence - a defined series of commands 
with specific settings and in a specific order that you can apply in a single step. You can 
apply this sequence to a single document, to several documents, or to an entire collection 
of documents. Your custom batch sequences appear on the list with the predefined 
sequences in the "Batch Processing" dialog box. When you quit the application, your 
batch-processing definitions are saved so that you can reuse them in later work sessions.  
  
AutoRedact™ plug-in installs several commands that can be accessed and executed via 
"Batch Sequences" dialog. These commands may be used alone or inside another batch 
sequences allowing you to incorporate redacting operations into your existing workflow. 
You need Adobe® Acrobat Professional® (versions 6.0 and 7.0) or Adobe® Acrobat® 
5.0 in order to have a batch processing available on your system. 
 
Another software product from EverMap, LLC - AutoBatch™ plug-in, can be used to 
invoke batch sequences from outside of the Adobe Acrobat®.  This allows for a complete 
integration of Acrobat® batch sequences into a larger document processing workflow. 
You can read more about AutoBatch™ plug-in at 
http://www.evermap.com/autobatch.asp. Free trial version of AutoBatch™ plug-in is 
available to download. 

Redacting Commands 
 
Acrobat batch processing can be accessed via “Advanced > Batch Processing…” from 
the main menu (in versions 6.0 and 7.0). AutoRedact™ installs the following commands 
into the batch processing framework: 
 

• Mark Up Text From Dictionary 
• Mark Up Text Patterns 
• Mark Up Text With Template 
• Mark Up All Text 
• Mark Up All Images 
• Convert Page Content To Image 
• Redact Document 
• Remove Markup Annotations 
• Remove All Attachments 

 
The functionality of each command is equivalent to the corresponding AutoRedact™ 
operation that is available from “Plug-ins > Redacting…” menu. Use these commands 
to create custom document redacting sequences. Each batch sequence can execute 

 
AutoRedact™ User’s Guide  70 

http://www.evermap.com/autobatch.asp


www.evermap.com  EverMap Company, LLC. 
 

multiple commands on input documents. Each command can be configured differently 
and uses separate redacting and markup preferences.  

Creating Custom Batch Sequences 
 
To create a custom document redacting batch sequence: 
 

1. Select “Advanced > Batch Processing” from the main menu. “Batch 
Sequence” dialog will pop up: 

 

 
 
2. Click “New Sequence…” button and “Name Sequence” dialog box will appear 

on the screen. Enter a unique name for this sequence and click the “OK” button to 
continue. 

 

 
 
3.  Click “Select Commands…” button to specify batch commands to execute on 
input documents. “Edit Sequence” dialog should appear on the screen. This dialog 
allows you to add and remove commands to the sequence, edit commands settings, 
specify a “silent” or “interactive” mode for each command and determine the order in 
which commands should be executed. Select the desired batch command from the list 
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and click “Add >>” button. This will add the selected command to the command 
sequence on the right side of the dialog. 

 

 
 

5. Click “Edit…” button to specify configuration settings for the command. Each 
command has a separate set of settings or preferences that can be configured 
during the design. For example, if you have two “Markup Text Patterns” 
commands then you have to specify their “Markup” preferences separately. 
Selecting preferences for one command in the sequence does not affect the 
settings of another one even if these two commands are of the same type. 

 
6. You can optionally toggle a batch command between “silent” and “interactive” 

modes by clicking on the small toggle button in front of each command entry.  
This option affects how the particular command is going to be executed during 
the runtime. If the command is executed in the “interactive” mode then it will 
prompt users to select its “settings” during the execution. If “interactive” mode is 
turned off (this is a default behavior) then this particular command is executed 
with the design-time settings without displaying any dialog boxes. This is the 
most common way to execute batch commands. 

 
7. Click “OK” button once you’ve finished configuring this batch sequence. “Edit 

Sequence” dialog box will be closed and you are back to “Edit Batch 
Sequence” dialog box. 

 
8. Specify input documents for this command sequence by selecting one of the 

available input options from “Run Commands On:” pull down menu. 
 

9. Select output location for processed documents from the “Select output 
location:” pull down menu. You can process one or more pre-selected files or a 
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content of the whole folder at the same time. Another option includes prompting 
for input each time this sequence is executed. 

 
10. Click “Output Options…” button to specify output file name and file type 

options in “Output Options” dialog. It’s typically a good idea to specify a 
different output file name by appending extra characters after the input document 
name. This will ensure that the original input document will not be overwritten 
when this batch sequence is executed. It will allow you to keep both original and 
processed documents. 

 

 
 
10. Click “OK” button once all the options has been set. This will save the batch 
sequence and add a new entry into the list of available batch sequences.  

Executing Batch Sequences 
 
Existing batch sequence can be executed from the “Batch Sequences” dialog box.  
 
1. Select “Advanced > Batch Processing” from the main menu to get to this dialog 
box.  
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2. Select a batch sequence from the list and click "Run Sequence" button. 
3. Click "OK" in confirmation dialog and Acrobat will prompt you to select input 
document(s) unless pre-selected files or folder were specified as input for the sequence.  
Make sure that documents you want to process are not currently open in Acrobat viewer. 
Select one or more input documents and click "OK" button to start processing.  
 
4. Open and review output documents in Adobe Acrobat (if necessary) to verify that 
batch sequence performs as expected. 

Advanced Batch Processing 
 
Batch sequences can be also executed from outside of Adobe Acrobat using AutoBatch™ 
plug-in from EverMap Company, LLC. This method of executing batch sequences is not 
originally available in Adobe Acrobat®. Many organizations require the ability to 
integrate Acrobat batch sequences into bigger document processing workflow. 
AutoBatch™ adds the command-line batch file functionality to the Adobe® Acrobat 
Professional®. It allows users to execute any existing Acrobat batch sequence from a 
command-line prompt or a batch file. The plug-in provides easy to use interface for 
creating batch files and does not require any type of programming. The output command-
prompt (DOS) batch file is created automatically based on user selection of an existing 
batch sequence and a required action. Resulting batch file can be started from a system 
command prompt and automatically launches Adobe® Acrobat Professional® that 
immediately starts executing a specified batch sequence. Adobe® Acrobat Professional® 
automatically exits once processing is complete. AutoBatch™ plug-in adds a missing 
functionality to the Acrobat software - ability to process PDF documents in the 
completely automatic mode. Visit http://www.evermap/autobatch.asp for more details.  
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Troubleshooting 
 
Q. I am trying to install AutoRedact™ plug-in but keep getting an error that tells 
me that “Can not find Adobe Acrobat (version 5.0 and up) installation on your 
system.”  
 
A. Most likely you do not have a full version of Adobe Acrobat software installed on 
your computer. AutoRedact™ plug-in does not work with the free Adobe Acrobat 
Reader. 
 
Q. Most menu entries on “Redacting” menu and buttons on “Redacting” toolbar are 
dimmed. Why is that? 
 
A. You have to open a PDF document first. Most of the menus and buttons will be 
dimmed if there is no active document open. Select “File > Open…” from the menu to 
open a PDF document for redacting. 
 
Q. I am getting “Document security settings do not permit document editing” message 
when I am trying to apply any redacting or markup operation. Why is that? 
 
A. This is because the document you are working with has security settings that do not 
allow document modifications. The author of PDF document can set restrictions that 
prevent you from using certain features. You can display security settings for the 
document by selecting “File > Document Properties…” from the menu. Choose 
“Security” tab in the “Document Properties” dialog. Modify security settings to allow 
document editing. 
 
Q. I am trying to search and markup text in the document but software does not 
seem to recognize any text in the document although I can see it on the page. What 
is wrong? 
 
A. Most likely you are working with a scanned document that does not contain any 
searchable text. Each page in such document is just an image. You need to run Optical 
Character Recognition (OCR) processing on this document to extract text from the image 
and make it searchable. In older versions of Adobe Acrobat this process is also known as 
“Paper Capture”.  Save the document to retain text elements created by OCR process. 
 
Q. Form fields are redacted completely even if they are not completely inside a 
redacting area. Why is that? 
 
A. Text form fields are processed differently from regular document content because of 
their dynamic nature. They can’t be partially redacted.  Although, AutoRedact™ can 
redact text form fields it’s recommended to flatten forms first before redacting. This will 
allow software to redact forms fields in the same way as regular text. 
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Q. I have a drawing in my document that is not redacted by the software. The 
drawing is covered by a redacting area. What is wrong? 
 
A. AutoRedact™ can redact text, images, form fields and annotations, but it can’t redact 
PostScript graphics or drawings. You will need to convert the whole page that contains 
this drawing to an image and redact it after that. Use “Plug-ins > Redacting > 
Advanced > Convert Page Content To Image…” operation to perform this 
conversion. 
 
Q. The software redacts more text that has been selected by redacting area.  
 
A. AutoRedact™ provides a number of options that determine how text is redacted. 
Software computes the overlap between redacting area and each character on the page 
and decides if it should be redacted based on “Overlap” settings. The best setting to use 
is “Redact if character overlaps at least 25%”. It will ensure that text elements that 
are only touched will not get deleted. You can change these settings in the “Redacting 
Preferences” dialog. Select “Plug-ins > Redacting > Preferences…” from the menu 
to access it. Click on “Redacting” tab to access redacting preferences. 
 
Q. The software only redacts few characters of the selected word. Some characters 
are left untouched. 
 
A. Check redacting preferences and modify current “Overlap” mode that determines how 
AutoRedact™ determines that certain character needs to be redacted. Software computes 
the overlap between redacting area and each character on the page and decides if it 
should be redacted based on “Overlap” settings. The best setting to use is “Redact if 
character overlaps at least 25%”. It will ensure that text elements that are only 
touched will not get deleted. If this is still not enough, you can specify for text to be 
redacted if it touches a redacting area (this will also redact text that is overlapped by the 
redacting area).  

Q. I want to print a document with redacting annotations but document is 
printed without any annotations. What is wrong? 
 
A. Make sure to specify that you want to print “Document and Markup” in the “Print 
Dialog”. Select “Document and Markup” from “Comments and Fields” pull down menu. 
You should immediately see redacting annotations in the print preview area. 
 
Q. I want to run AutoRedact™ plug-in in the batch mode but I do not see 
“Advanced > Batch Processing…” menu in my installation of Adobe Acrobat.  
 
A. Batch processing framework is only available in Adobe Acrobat Professional product. 
You will need to upgrade to a Professional version if you want to create and execute 
batch sequences.  
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Technical Support 
 
If you have problems, questions or new feature requests while using AutoRedact™ plug-
in you can contact our technical support. Make sure to first look at the relevant chapter in 
this manual and see if there is an answer or an explanation for your question. This manual 
assumes you have a working knowledge of your computer and its operating conventions, 
have some basic experience working with PDF documents in Adobe Acrobat® or Adobe 
Acrobat Professional®, including how to open, save, close and print documents. It also 
assumes that you are familiar with basic menus and commands available in Adobe 
Acrobat® products. If you have technical questions that are not directly related to 
AutoRedact™ functionality we suggest consulting Adobe Acrobat® “Complete Help” 
and “How To” pages. For detailed information on how to use “Complete Help”, choose 
“Help > Complete Acrobat 7.0 Help” from the main menu.  
Technical support can be contacted via e-mail at tech@evermap.com or using special 
form on our web site at http://www.evermap.com/techsupport.asp. Technical support is 
free of charge for all users of our software, including users of the free evaluation version. 
 
In order to provide a prompt and quality technical support we typically ask for the 
following information: 
 

• Version of operating system you are using. 
 
• Version and build date of AutoRedact™ software (Select “Help > About Third-

party Plug-ins > AutoRedact…” from the main Acrobat menu to access this 
information). 

 
• Sample copy of the document you are working with (in case if a document is 

confidential or classified please provide a sample that closely resembles it or has 
been created using the same procedure or workflow). This is crucial for providing 
you with fast and efficient technical support. Most problems or questions can be 
quickly answered if we have access to a document sample, even if it’s small. 

 
• AutoRedact™ preferences you are currently using. You can save them to the 

settings file and attach it to the email message. Select “Plug-ins > Redacting > 
Manage Preferences > Save Preferences To File…” from the main menu to 
save your current redacting preferences to a settings file. This file will allow us to 
have a full description of your AutoRedact™ configuration. It contains only 
application settings and does not include redacting dictionaries or any private 
information from your computer. 

 
• Short description of the question or a problem you are experiencing. 

 
• Name and contact information of the person to whom we should address our 

correspondence. 
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Appendix A 
Freedom of Information Act (FOIA) Exemptions 
 
The Freedom of Information Act is the federal law that makes government information 
accessible to the people. The law is based on the presumption that individuals have a 
right to know what their government is up to and that government agencies have a duty to 
provide full disclosure of all records that are not specifically and reasonably exempt. 
The Freedom of Information Act (FOIA) was enacted in 1966 to provide people a means 
to access federal agency records, with the exception of those excluded from consideration 
under the FOIA or protected by nine FOIA exemptions. It is the policy of each federal 
agency to make records available to the public to the greatest extent possible, in keeping 
with the spirit of the FOIA, while at the same time protecting sensitive information that 
may be withheld pursuant to one of the FOIA's exemptions. In accordance with 5 U.S.C.§ 
552(b), the following is a list of these exemptions which apply to Government 
information subject to the FOIA:  
 
(b)(1) EXEMPTION - Protects Classified Matters of National Defense or Foreign Policy.  
This exemption protects from disclosure national security information concerning the 
national defense or foreign policy, provided that it has been properly classified in 
accordance with the substantive and procedural requirements of an executive order.  
 
(b)(2) EXEMPTION - Internal Personnel Rules and Practices. 
This exemption exempts from mandatory disclosure records "related solely to the internal 
personnel rules and practices of an agency." Courts have interpreted the exemption to 
encompass two distinct categories of information:  
(a) Internal matters of a relatively trivial nature--sometimes referred to as "low2" 
information; and  
(b) More substantial internal matters, the disclosure of which would risk circumvention 
of a legal requirement--sometimes referred to as "high 2" information.  
 
(b)(3) EXEMPTION - Information Specifically Exempted by Other Statutes  
This exemption incorporates the disclosure prohibitions that are contained in various 
other federal statutes. As originally enacted in 1966, Exemption 3 was broadly phrased so 
as to simply cover information "specifically exempted from disclosure by statute." The 
new Exemption 3 statute prohibits agencies from releasing under the FOIA any proposal 
"submitted by a contractor in response to the requirements of a solicitation for a 
competitive proposal," unless that proposal "is set forth or incorporated by reference in a 
contract entered into between the agency and the contractor that submitted the proposal."  
 
(b)(4) EXEMPTION - Trade Secrets, Commercial or Financial Information  
This exemption protects "trade secrets and commercial or financial information obtained 
from a person [that is] privileged or confidential." This exemption is intended to protect 
the interests of both the government and submitters of information.  
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(b)(5) EXEMPTION - Privileged Interagency or Intra-agency Memoranda or Letters  
This exemption protects "interagency or intra-agency memorandums or letters which 
would not be available by law to a party ...in litigation with the agency." As such, it has 
been construed to "exempt those documents and only those documents that are normally 
privileged in the civil discovery context."  
 
(b)(6) EXEMPTION - Personal Information Affecting an Individual's Privacy  
This exemption permits the government to withhold all information about individuals in 
"personnel and medical files and similar files" when the disclosure of such information 
"would constitute a clearly unwarranted invasion of personal privacy." This exemption 
cannot be invoked to withhold from requester information pertaining to the requester.  
 
(b)(7) EXEMPTION - Investigatory Records Compiled for Law Enforcement Purposes  
As amended, this exemption protects from disclosure "records or information compiled 
for law enforcement purposes....". 
 
EXEMPTION 7(A) Records or information the disclosure of which could reasonably be 
expected to interfere with enforcement proceedings. This exemption authorizes the 
withholding of "records or information compiled for law enforcement purposes, but only 
to the extent that production of such law enforcement records or information ... could 
reasonably be expected to interfere with enforcement proceedings."  
 
EXEMPTION 7(B) Records, the disclosure of which would deprive a person of a right to 
a fair trial or an impartial adjudication. This exemption is aimed at preventing prejudicial 
pretrial publicity that could impair a court proceeding, protects "records or information 
compiled for law enforcement purposes [the disclosure of which] would deprive a person 
of a right to a fair trial or an impartial adjudication."  
 
EXEMPTION 7(C) Personal Information in Law Enforcement Records. This exemption 
provides protection for personal information in law enforcement records. This exemption 
is the law enforcement counterpart to Exemption 6, providing protection for law 
enforcement information the disclosure of which "could reasonably be expected to 
constitute an unwarranted invasion of personal privacy."  
 
EXEMPTION 7 (D) Identity of a Confidential Source. This exemption provides 
protection for "records or information compiled for law enforcement purposes [which] 
could reasonably be expected to disclose the identity of a confidential source --including 
a State, local, or foreign agency or authority or any private institution which furnished 
information on a confidential basis--and, in the case of a record or information compiled 
by a criminal law enforcement authority in the course of a criminal investigation, or by an 
agency conducting a lawful national security intelligence investigation, information 
furnished by a confidential source."  
 
EXEMPTION 7(E) Circumvention of the Law. This exemption affords protection to all 
law enforcement information which "would disclose techniques and procedures for law 
enforcement investigations or prosecutions, or would disclose guidelines for law 
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enforcement investigations or prosecutions if such disclosure could reasonably be 
expected to risk circumvention of the law."  
 
EXEMPTION 7(F) To Protect the Physical Safety of a Wide Range of Individuals. This 
exemption permits the withholding of information necessary to protect the physical safety 
of a wide range of individuals. Whereas Exemption 7(F) previously protected records that 
"would... endanger the life or physical safety of law enforcement personnel," the 
amended exemption provides protection to "any individual" when disclosure of 
information about him or her "could reasonably be expected to endanger [his/her] life or 
physical safety."  
 
(b)(8) EXEMPTION - Regulation of Financial Institutions  
This exemption protects matters that are "contained in or related to examination, 
operating, or condition reports prepared by,on behalf of, or for the use of an agency 
responsible for the regulation or supervision of financial institutions."  
 
(b)(9) EXEMPTION - Geological and Geophysical Information Concerning Wells  
This exemption covers "geological and geophysical information and data, including 
maps, concerning wells."  
 
AutoRedact™ software comes with standard pre-configured FOIA exemption code group 
that is ready to use for redacting documents. 
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Privacy Act of 1974  
 
The Privacy Act of 1974 works in tandem with FOIA to regulate federal agency records 
about individuals, restricting the disclosure of personal information that might violate 
privacy while allowing individuals access to records about themselves. You can find 
detailed information related to Privacy Act and its exemption online at any governmental 
agency website. Each agency maintains a web page with detailed explanations about 
FOIA and Privacy Act exemptions that are agency specific. You can read full explanation 
of Privacy Act exemptions online at http://www.usdoj.gov/foia/privstat.htm. 
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Glossary of Terms 
 

Batch Processing 
 
Adobe Acrobat Professional 6.0 and 7.0 provide batch processing capability that allow 
creating of custom document processing sequences and applying them to multiple files at 
once. 

Batch Sequence 
 
An executable sequence of batch commands in Adobe Acrobat batch processing 
framework. Individual commands are chained in the document processing sequence that 
can be applied as a single operation to multiple files at once. 

Batch Command 
 
An individual processing step in the Adobe Acrobat batch sequence. Adobe Acrobat 
comes with few standard batch commands such as “Set Security” or “Print All”. Third 
party may also add their own commands to the batch processing framework. 
AutoRedact™ offers most of it functionality as batch commands. Each batch command is 
expects an input document, performs some processing and passes the result to the next 
command in the sequence. 

Exemption Code 
 
An exemption code is combination of letters and numbers that indicate the reason why a 
certain piece of information has been redacted from the document. Exemption codes refer 
to corresponding sections of federal or state law. 

OCR (Optical Character Recognition) 
 
Optical Character Recognition (OCR) refers to the process by which scanned images are 
electronically "read" to convert them into editable and searchable text. This conversion is 
performed after scanning, and adds formatted text behind the images. This process was 
called “Paper Capture” in versions of Adobe Acrobat prior 7.0. 

PDF Text Element 
 
An element in PDF document that represents text information. PDF document can be 
searched for occurrence of the specific text if it contains text elements. Text elements 
may represent one or more characters and do not necessary represent complete words. 
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Text elements also contain font and color information that define their appearance on the 
page. 

PDF Image 
 
An element in PDF document that represents an image. Scanned documents always 
contain images that represent the appearance of the individual pages. Images can’t be 
searched and are just rectangular arrays of pixels. Optical Character Recognition (OCR) 
can be applied to images to extract text information from them and make a document 
searchable. 

Redacting 
 
Redaction, by definition, means removing certain types of information from documents. 
In the context of United States government agency documents, redaction generally refers 
more specifically to the process of removing classified information from a document 
prior to its publication, during declassification. 

Redacting Annotation 
 
An Adobe Acrobat annotation that marks up a certain area on a page for redacting. 
AutoRedact™ uses highlight, cross-out, underline and rectangle annotation as redacting 
annotation. Redacting annotation may also contain a corresponding exemption code. 

Redacting Dictionary 
 
A redacting dictionary is a collection of individual redacting entries that used for 
redacting markup. Each entry consists of redacting text and the optional exemption 
code. Redacting text represents any text, word or sentence that needs to be found in the 
document and marked for redacting. Each redacting text entry is unique within the 
dictionary.  

Redacting Template 
 
A redacting template is a collection of redacting annotations that specify what areas on 
the page need to be redacted. 

Redacting Tool 
 
AutoRedact™ plug-in offers redacting tool for manual markup of areas on the page for 
redacting. Redacting tool combines rectangle drawing tool with exemption code selection 
toolbar. 
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Redacting Toolbar 
 
AutoRedact™ adds a toolbar to the Adobe Acrobat that provides short-cuts to many 
redacting operations available in the software. 
 

 
 

Regular Expression 
 
A regular expression (often abbreviated as regexp, regex, or regxp, with plural forms 
regexps, regexes, or regexen) is a string that describes or matches a set of strings, 
according to certain syntax rules. Regular expressions are used by many text editors and 
utilities to search and manipulate bodies of text based on certain patterns. AutoRedact™ 
software uses regular expressions in the “Mark Up Text Pattern” operation to describe 
a text that needs to be marked for redacting. 

Text Pattern 
 
Any text word, phrase or a sentence that exhibits common appearance may represent a 
text pattern. Phone numbers, email addresses, social security numbers are all examples of 
the text patterns. 
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